summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordevninja2016-04-11 12:39:03 -0400
committerdevninja2016-04-11 12:39:03 -0400
commitdf2d30559a9677450cee01e405c5588734bd7d77 (patch)
treeb7121851b801d5f3d1846b1419fef55f221caa30
parent87fe64e4278d554f1e0dae963a5e9a6d51dd2dd0 (diff)
downloadaur-df2d30559a9677450cee01e405c5588734bd7d77.tar.gz
fixed permissions.
added unpack200, so this actually works as intended
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
-rw-r--r--i2pbote.install9
3 files changed, 29 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 456cef5c7e19..f44d91fe7336 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
# Generated by mksrcinfo v8
-# Mon Apr 11 15:04:53 UTC 2016
+# Mon Apr 11 16:38:53 UTC 2016
pkgbase = i2p-plugin-i2pbote
pkgdesc = A distributed email client for I2P
pkgver = 0.4.3
- pkgrel = 1
+ pkgrel = 2
url = http://bote.i2p/
+ install = i2pbote.install
arch = any
groups = i2p-plugins
license = GPLv3
makedepends = unzip
+ makedepends = java-runtime-common
depends = i2p
provides = i2pbotes
noextract = file://i2pbote.su3
diff --git a/PKGBUILD b/PKGBUILD
index 55557dab97b8..6c1fb71c814f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,20 +8,31 @@
_pluginame=i2pbote
pkgname=i2p-plugin-${_pluginame}
pkgver=0.4.3
-pkgrel=1
+pkgrel=2
pkgdesc="A distributed email client for I2P"
arch=('any')
url="http://bote.i2p/"
license=('GPLv3')
groups=('i2p-plugins')
depends=('i2p')
-makedepends=('unzip')
+makedepends=('unzip' 'java-runtime-common')
provides=('i2pbotes')
# get this from http://bote.i2p/i2pbote.su3
source=("file://${_pluginame}.su3")
noextract=("file://${_pluginame}.su3")
+install="${_pluginame}.install"
sha256sums=('19ae8e09f932d111dc8016e9a3c4f6fa78c059a650d3d735de08d5c1233b7780')
+_unpack_dir() {
+ # use this to unpack the .war/.jar files. I2P does this automaticly on install
+ # but it will not work otherwise
+ local indir="$@"
+ for file in $indir/*.pack;do
+ unpack200 $file ${file%.pack}
+ rm $file
+ done
+}
+
prepare() {
cd "${srcdir}"
@@ -37,7 +48,9 @@ prepare() {
package() {
cd "${srcdir}"
- mkdir -p "${pkgdir}/opt/i2p/plugins/.i2p/"
+ mkdir -p "${pkgdir}/opt/i2p/.i2p/plugins/"
cp -Ra "i2p" "${pkgdir}/opt/i2p/.i2p/plugins/${_pluginame}"
+ _unpack_dir "${pkgdir}/opt/i2p/.i2p/plugins/${_pluginame}/lib"
+ _unpack_dir "${pkgdir}/opt/i2p/.i2p/plugins/${_pluginame}/console/webapps"
}
diff --git a/i2pbote.install b/i2pbote.install
new file mode 100644
index 000000000000..9edc00e91afb
--- /dev/null
+++ b/i2pbote.install
@@ -0,0 +1,9 @@
+post_install() {
+ post_upgrade
+}
+
+post_upgrade() {
+ systemd-tmpfiles --create i2prouter.conf
+ chown -R i2p:i2p /opt/i2p/.i2p/plugins/i2pbote
+ chmod 700 /opt/i2p/.i2p/plugins/i2pbote
+}