summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-12-27 13:41:40 +0100
committerM0Rf302015-12-27 13:41:40 +0100
commit4724e8b9c89ad3d06a19c52827d9dcd646825113 (patch)
tree111c5b734f0e7b021a9a6803e66185c155f9776e
parenta71292a853e70ebe06c88cb71e0f7fba91fad089 (diff)
downloadaur-4724e8b9c89ad3d06a19c52827d9dcd646825113.tar.gz
2.2.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--i2pd.service2
3 files changed, 23 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cbdaf2d66e5..787335364e21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Dec 27 12:41:26 UTC 2015
pkgbase = i2pd
pkgdesc = Simplified C++ implementation of I2P client
- pkgver = 2.1.0
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/PurpleI2P/i2pd
install = i2pd.install
@@ -10,14 +12,16 @@ pkgbase = i2pd
makedepends = boost
makedepends = cmake
depends = boost-libs
+ depends = libupnp
depends = openssl
+ depends = zlib
conflicts = i2pd-git
- source = https://github.com/PurpleI2P/i2pd/archive/2.1.0.tar.gz
+ source = https://github.com/PurpleI2P/i2pd/archive/2.2.0.tar.gz
source = i2pd.service
source = i2p.conf
source = i2pd.tmpfiles.conf
- md5sums = 3375da5f15cd2ce27c870f192f1885ad
- md5sums = c37b5470c959e826be8eb40c8f1ece93
+ md5sums = 62aa474f0039ab1791c3b0958ba87adc
+ md5sums = 7125bfdcbb5050c5fbf7531861dc82fa
md5sums = b145e41e22806bd4ca4f4064ec4721a2
md5sums = 862be388708f2b1bd5f727715ec7508d
diff --git a/PKGBUILD b/PKGBUILD
index a2fb9d383065..192765ec4aeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: M0Rf30
pkgname=i2pd
-pkgver=2.1.0
+pkgver=2.2.0
pkgrel=1
pkgdesc="Simplified C++ implementation of I2P client"
arch=('i686' 'x86_64')
url="https://github.com/PurpleI2P/i2pd"
license=('GPL2')
-depends=(boost-libs 'openssl')
+depends=('boost-libs' 'libupnp' 'openssl' 'zlib')
makedepends=(boost cmake)
conflicts=(i2pd-git)
install=i2pd.install
@@ -18,18 +18,25 @@ source=(https://github.com/PurpleI2P/${pkgname}/archive/${pkgver}.tar.gz
build() {
cd $srcdir/$pkgname-$pkgver
- make CXXFLAGS="$CXXFLAGS"
+ cd build
+ mkdir tmp
+ cd tmp
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DWITH_BINARY=ON -DWITH_LIBRARY=ON -DWITH_UPNP=ON ..
+ make
}
package() {
cd $srcdir/$pkgname-$pkgver
- install -Dm755 i2p $pkgdir/usr/bin/i2p
+ cd build/tmp
+ make DESTDIR=$pkgdir install
+
+
install -Dm0644 $srcdir/i2pd.service $pkgdir/usr/lib/systemd/system/i2pd.service
- install -Dm0644 ../i2p.conf $pkgdir/var/lib/i2pd/i2p.conf
+ install -Dm0644 $srcdir/i2p.conf $pkgdir/var/lib/i2pd/i2p.conf
install -Dm0644 $srcdir/i2pd.tmpfiles.conf $pkgdir/usr/lib/tmpfiles.d/i2pd.conf
}
-md5sums=('3375da5f15cd2ce27c870f192f1885ad'
- 'c37b5470c959e826be8eb40c8f1ece93'
+md5sums=('62aa474f0039ab1791c3b0958ba87adc'
+ '7125bfdcbb5050c5fbf7531861dc82fa'
'b145e41e22806bd4ca4f4064ec4721a2'
'862be388708f2b1bd5f727715ec7508d')
diff --git a/i2pd.service b/i2pd.service
index 8de42e2f3c42..871311fe5ee3 100644
--- a/i2pd.service
+++ b/i2pd.service
@@ -6,7 +6,7 @@ After=network.target
User=i2p
Group=i2p
Type=forking
-ExecStart=/usr/bin/i2p --conf=/var/lib/i2pd/i2p.conf --service=1 --daemon=1
+ExecStart=/usr/bin/i2pd --conf=/var/lib/i2pd/i2p.conf --service=1 --daemon=1
ExecReload=/usr/bin/kill -HUP $MAINPID
PIDFile=/run/i2pd.pid
KillSignal=SIGINT