summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAtreya Shankar2020-06-27 03:04:49 +0200
committerAtreya Shankar2020-06-27 03:04:49 +0200
commit7fa5014b35be92614e8e6bdccbc5b997199e63ea (patch)
tree87b249246d252177445df167b18273c01a63d8fd
downloadaur-7fa5014b35be92614e8e6bdccbc5b997199e63ea.tar.gz
Release v1.6.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e782f536ea17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = i3-balance-workspace
+ pkgdesc = Balance windows and workspaces in i3wm
+ pkgver = 1.6.2
+ pkgrel = 1
+ url = https://github.com/atreyasha/i3-balance-workspace
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python>=3.5.0,
+ depends = python-i3ipc
+ source = https://files.pythonhosted.org/packages/source/i/i3-balance-workspace/i3-balance-workspace-1.6.2.tar.gz
+ md5sums = 875b04190774c147859274f6c729e0de
+
+pkgname = i3-balance-workspace
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a2940dbcfa1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Atreya Shankar <shankar.atreya@gmail.com>
+
+_module='i3-balance-workspace'
+pkgname="$_module"
+pkgver=1.6.2
+pkgrel=1
+pkgdesc="Balance windows and workspaces in i3wm"
+url='https://github.com/atreyasha/i3-balance-workspace'
+depends=('python>=3.5.0', 'python-i3ipc')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module:0:1}/${_module}/${_module}-${pkgver}.tar.gz")
+md5sums=('875b04190774c147859274f6c729e0de')
+
+build() {
+ cd "$_module-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_module-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}