summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThe-Repo-Club2023-02-20 12:01:57 +0000
committerThe-Repo-Club2023-02-20 12:01:57 +0000
commit4f3845b144a7386b3bd446951ba65d3ebd68d0fe (patch)
tree1a56a3d8e2c797d4fe8279e444f33fa64215d9e2
downloadaur-4f3845b144a7386b3bd446951ba65d3ebd68d0fe.tar.gz
First Push
-rw-r--r--.SRCINFO44
-rw-r--r--.gitignore9
-rw-r--r--LICENSE26
-rw-r--r--PKGBUILD59
4 files changed, 138 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4f82b058415
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = i3-doubleborders
+ pkgdesc = Improved dynamic tiling window manager
+ pkgver = 4.22
+ pkgrel = 1
+ url = https://i3wm.org
+ arch = x86_64
+ groups = i3
+ license = BSD
+ makedepends = meson
+ makedepends = xmlto
+ depends = libev
+ depends = libxkbcommon-x11
+ depends = pango
+ depends = startup-notification
+ depends = xcb-util-cursor
+ depends = xcb-util-keysyms
+ depends = xcb-util-wm
+ depends = xcb-util-xrm
+ depends = yajl
+ optdepends = dmenu: for the default program launcher
+ optdepends = rofi: for a modern dmenu replacement
+ optdepends = i3lock: for the default screen locker
+ optdepends = xss-lock: for the default screen locker
+ optdepends = i3status: for the default status bar generator
+ optdepends = perl: for i3-save-tree and i3-dmenu-desktop
+ optdepends = perl-anyevent-i3: for i3-save-tree
+ optdepends = perl-json-xs: for i3-save-tree
+ provides = i3-wm
+ conflicts = i3-wm
+ replaces = i3
+ replaces = i3bar
+ replaces = i3-gaps
+ backup = etc/i3/config
+ source = https://i3wm.org/downloads/i3-4.22.tar.xz
+ source = https://i3wm.org/downloads/i3-4.22.tar.xz.asc
+ source = https://github.com/orestisfl/i3/commit/c305798d42.patch
+ source = https://gist.githubusercontent.com/The-Repo-Club/b7111e9028cdfb3e6c60614cdfd19875/raw/178d5273fa91dcf6ed03d96187e78e841c814f35/x.diff
+ validpgpkeys = 424E14D703E7C6D43D9D6F364E7160ED4AC8EE1D
+ b2sums = fa179f445ba4286bfeec98dc7a2e1dfad14bda6874e84878a48ee5890ed4cf3a90fc542e8e14aedaaba3abebc8d280284a3b00e838da70a783064a4bd271ca41
+ b2sums = 9afac91e427f2a24120b257e6fb2dcc0879a86bc7957fe4562099778f3ee8300a70e71b7e0170d1eab89940ca89a42937da9eb5bd3015f9aabb82a96459a566a
+ b2sums = e8e9ef5d8ff25b010fe36ff395f7fb4368e4d8bcb843b42ce06758184cc7b6854ec7efc71c91bc18290de2d4aba3b878453f47f84abc5ab3a0877c523014d701
+ b2sums = c2257a564975f4649ec275587dea790cfed8dd0e3e6ee69f6ee60ac3f638d0510d930c74cd2cb6dfc15f4591c2ae9fe1b1d9f84f23967e1992f93a91b91cd301
+
+pkgname = i3-doubleborders
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dcf483407716
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!LICENSE
+# etc...
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1f0872c7a472
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,26 @@
+Copyright © 2009, Michael Stapelberg and contributors
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+3. Neither the name of the copyright holder nor the names of its
+ contributors may be used to endorse or promote products derived
+ from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eec0a79d02a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Levente Polyak <anthraxx@archlinux.org>
+# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
+# Maintainer: T.J. Townsend <blakkheim@archlinux.org>
+# Contributor: Thorsten Töpper <atsutane-tu@freethoughts.de>
+# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
+# shellcheck disable=all
+
+pkgname=i3-doubleborders
+pkgver=4.22
+pkgrel=1
+pkgdesc='Improved dynamic tiling window manager'
+arch=('x86_64')
+url=https://i3wm.org
+license=('BSD')
+groups=('i3')
+depends=('libev' 'libxkbcommon-x11' 'pango' 'startup-notification'
+ 'xcb-util-cursor' 'xcb-util-keysyms' 'xcb-util-wm' 'xcb-util-xrm'
+ 'yajl')
+makedepends=('meson' 'xmlto')
+optdepends=('dmenu: for the default program launcher'
+ 'rofi: for a modern dmenu replacement'
+ 'i3lock: for the default screen locker'
+ 'xss-lock: for the default screen locker'
+ 'i3status: for the default status bar generator'
+ 'perl: for i3-save-tree and i3-dmenu-desktop'
+ 'perl-anyevent-i3: for i3-save-tree'
+ 'perl-json-xs: for i3-save-tree')
+replaces=('i3' 'i3bar' 'i3-gaps')
+provides=('i3-wm')
+conflicts=('i3-wm')
+backup=('etc/i3/config')
+source=("$url/downloads/i3-$pkgver.tar.xz"{,.asc}
+ "https://github.com/orestisfl/i3/commit/c305798d42.patch"
+ "https://gist.githubusercontent.com/The-Repo-Club/b7111e9028cdfb3e6c60614cdfd19875/raw/178d5273fa91dcf6ed03d96187e78e841c814f35/x.diff")
+b2sums=('fa179f445ba4286bfeec98dc7a2e1dfad14bda6874e84878a48ee5890ed4cf3a90fc542e8e14aedaaba3abebc8d280284a3b00e838da70a783064a4bd271ca41'
+ '9afac91e427f2a24120b257e6fb2dcc0879a86bc7957fe4562099778f3ee8300a70e71b7e0170d1eab89940ca89a42937da9eb5bd3015f9aabb82a96459a566a'
+ 'e8e9ef5d8ff25b010fe36ff395f7fb4368e4d8bcb843b42ce06758184cc7b6854ec7efc71c91bc18290de2d4aba3b878453f47f84abc5ab3a0877c523014d701'
+ 'c2257a564975f4649ec275587dea790cfed8dd0e3e6ee69f6ee60ac3f638d0510d930c74cd2cb6dfc15f4591c2ae9fe1b1d9f84f23967e1992f93a91b91cd301')
+validpgpkeys=('424E14D703E7C6D43D9D6F364E7160ED4AC8EE1D') # Michael Stapelberg <michael@stapelberg.de>
+
+prepare() {
+ cd i3-$pkgver
+ patch -Np1 -i ../c305798d42.patch
+ patch -Np1 -i ../x.diff
+}
+
+build() {
+ cd i3-$pkgver
+ arch-meson build
+ ninja -C build
+}
+
+package() {
+ cd i3-$pkgver
+ DESTDIR="$pkgdir" ninja -C build install
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file