summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sichevoi2022-02-03 05:30:14 +0100
committerAndrew Sichevoi2022-02-03 05:30:14 +0100
commitb6e27dc72beaa7aa2af757a09f843d114f35c968 (patch)
tree93d03d1a0859afde1e89e35368024142843c08b9
downloadaur-b6e27dc72beaa7aa2af757a09f843d114f35c968.tar.gz
Initial version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
-rw-r--r--i3-extra-workspace.install8
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ef1d2b4213c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = i3-extra-workspace-git
+ pkgdesc = Workspace-specific scratchpads (extra workspaces) for i3
+ pkgver = r5.feb0e25
+ pkgrel = 1
+ url = https://github.com/thekondor/i3-extra-workspace
+ install = i3-extra-workspace.install
+ arch = any
+ license = Apache 2.0
+ makedepends = git
+ makedepends = go
+ depends = i3-wm
+ provides = i3-extra-workspace
+ conflicts = i3-extra-workspace
+ source = git+https://github.com/thekondor/i3-extra-workspace.git
+ md5sums = SKIP
+
+pkgname = i3-extra-workspace-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08a951efc74a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Andrew Sichevoi, http://thekondor.net
+
+_pkgname=i3-extra-workspace
+_gitname=i3-extra-workspace
+pkgname=$_pkgname-git
+pkgver=r5.feb0e25
+pkgrel=1
+pkgdesc="Workspace-specific scratchpads (extra workspaces) for i3"
+
+arch=('any')
+url="https://github.com/thekondor/i3-extra-workspace"
+license=('Apache 2.0')
+depends=('i3-wm')
+makedepends=('git' 'go')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/thekondor/$_gitname.git")
+md5sums=('SKIP')
+install="$_pkgname.install"
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_gitname"
+ go test -v ./... && go build
+}
+
+package() {
+ cd "$_gitname"
+
+ install -Dm644 "$srcdir/$_gitname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/$_gitname/dist/hotkeys.conf.example" "$pkgdir/usr/share/$pkgname/hotkeys.conf.example"
+ install -Dm755 "$srcdir/$_gitname/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+}
diff --git a/i3-extra-workspace.install b/i3-extra-workspace.install
new file mode 100644
index 000000000000..eaf02a1efe7a
--- /dev/null
+++ b/i3-extra-workspace.install
@@ -0,0 +1,8 @@
+post_install() {
+cat <<End-of-message
+
+Copy /usr/share/i3-extra-workspace-git/hotkeys.conf.example into ~/.config/i3/hotkeys.conf and include to the main i3 config.
+Or use your very own hotkeys.
+
+End-of-message
+}