summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRagnar Groot Koerkamp2021-05-19 18:50:10 +0200
committerRagnar Groot Koerkamp2021-05-19 18:50:10 +0200
commit6db69ab380e2954fa3bc8074f48ba467d5a7fece (patch)
treea71be62e16995ddf2b86b11b31a7c06d4e2c3f9e
downloadaur-6db69ab380e2954fa3bc8074f48ba467d5a7fece.tar.gz
Package for i3-focus-last
Follows guidelines from https://wiki.archlinux.org/title/AUR_submission_guidelines
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9c67b6ab62e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = i3-focus-last-git
+ pkgdesc = Focus last window on i3
+ pkgver = r43.15adab0
+ pkgrel = 1
+ url = https://github.com/lbonn/i3-focus-last
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = rust
+ makedepends = cargo
+ source = i3-focus-last::git+https://github.com/lbonn/i3-focus-last
+ md5sums = SKIP
+
+pkgname = i3-focus-last-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..5a310014b837
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Ragnar Groot Koerkamp <ragnar.grootkoerkamp at gmail dot com>
+pkgname=i3-focus-last-git
+_pkgname=i3-focus-last
+pkgver=r43.15adab0
+pkgrel=1
+pkgdesc="Focus last window on i3"
+arch=('any')
+url="https://github.com/lbonn/i3-focus-last"
+license=('MIT')
+makedepends=('git' 'rust' 'cargo')
+source=("${_pkgname}::git+https://github.com/lbonn/i3-focus-last")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ RUSTUP_TOOLCHAIN=stable cargo build --release --locked --all-features --target-dir=target
+
+}
+
+check() {
+ RUSTUP_TOOLCHAIN=stable cargo test --release --locked --target-dir=target
+}
+
+package() {
+ install -Dm 755 target/release/${_pkgname} -t "${pkgdir}/usr/bin"
+}