summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimur Demin2021-01-31 00:50:50 +0500
committerTimur Demin2021-01-31 00:50:50 +0500
commit443595946e0a3c31616132a503728f0f7b2a7dae (patch)
tree0aa118d14aef3786e9c195010e3e7900ee71ecad
downloadaur-443595946e0a3c31616132a503728f0f7b2a7dae.tar.gz
Initial commit at 4.19-1
-rw-r--r--.SRCINFO38
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD44
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1ba7116a277
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = i3-gaps-desktop
+ pkgdesc = A fork of i3-gaps with desktop manager support
+ pkgver = 4.19
+ pkgrel = 1
+ url = https://git.tdem.in/tdemin/i3
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = bison
+ makedepends = flex
+ makedepends = asciidoc
+ makedepends = xmlto
+ makedepends = meson
+ depends = xcb-util-keysyms
+ depends = xcb-util-wm
+ depends = libev
+ depends = yajl
+ depends = startup-notification
+ depends = pango
+ depends = perl
+ depends = xcb-util-cursor
+ depends = xcb-util-xrm
+ depends = libxkbcommon-x11
+ optdepends = rxvt-unicode: The terminal emulator used in the default config.
+ optdepends = dmenu: As menu.
+ optdepends = i3lock: For locking your screen.
+ optdepends = i3status: To display system information with a bar.
+ optdepends = perl-json-xs: For i3-save-tree
+ optdepends = perl-anyevent-i3: For i3-save-tree
+ provides = i3-wm
+ conflicts = i3-wm
+ options = docs
+ backup = etc/i3/config
+ source = i3-gaps-desktop-4.19.tar.gz::https://git.tdem.in/tdemin/i3/archive/4.19-desktop.tar.gz
+ sha256sums = 907afaf0346f321a46912e513a47cea8245e869d330f8e8c3c57a87a2ad03dce
+
+pkgname = i3-gaps-desktop
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d8990fa1691
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Timur Demin <me@tdem.in>
+# Contributor: Morten Linderud <foxboron@archlinux.org>
+# Contributor: Ingo Bürk <admin at airblader dot de>
+
+# ported from i3-gaps PKGBUILD
+
+pkgname=i3-gaps-desktop
+pkgver=4.19
+pkgrel=1
+pkgdesc='A fork of i3-gaps with desktop manager support'
+arch=('i686' 'x86_64')
+url='https://git.tdem.in/tdemin/i3'
+license=('BSD')
+provides=('i3-wm')
+conflicts=('i3-wm')
+depends=('xcb-util-keysyms' 'xcb-util-wm' 'libev' 'yajl'
+ 'startup-notification' 'pango' 'perl' 'xcb-util-cursor' 'xcb-util-xrm'
+ 'libxkbcommon-x11')
+makedepends=('bison' 'flex' 'asciidoc' 'xmlto' 'meson')
+optdepends=('rxvt-unicode: The terminal emulator used in the default config.'
+ 'dmenu: As menu.'
+ 'i3lock: For locking your screen.'
+ 'i3status: To display system information with a bar.'
+ 'perl-json-xs: For i3-save-tree'
+ 'perl-anyevent-i3: For i3-save-tree')
+backup=(etc/i3/config)
+options=('docs')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}-desktop.tar.gz")
+sha256sums=('907afaf0346f321a46912e513a47cea8245e869d330f8e8c3c57a87a2ad03dce')
+
+build() {
+ cd "i3"
+ arch-meson \
+ -Ddocs=true \
+ -Dmans=true \
+ ../build
+ meson compile -C ../build
+}
+
+package() {
+ cd "i3"
+ DESTDIR="$pkgdir" meson install -C ../build
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE
+}