summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFinn2022-04-16 10:47:30 +0200
committerFinn2022-04-16 10:47:30 +0200
commit6a942271e2ad42ce56da24cfa40a731c1019c8bf (patch)
treeb870d08596f77cda177099e264cdcebe0dfc9bee
parentfb943ee7d293b43346a082aa8042e61f6cb6f800 (diff)
downloadaur-6a942271e2ad42ce56da24cfa40a731c1019c8bf.tar.gz
move to new repo/update build process
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD51
2 files changed, 26 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab8ea06fd6bb..2ed5c59450f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = i3-gaps-rounded-git
pkgdesc = A fork of i3wm tiling window manager with more features, including gaps and rounded corners
- pkgver = 4.16.1.r184.g00181678
- pkgrel = 3
- url = https://github.com/resloved/i3
+ pkgver = 4.20.1.r82.gad7c74ac
+ pkgrel = 2
+ url = https://github.com/FinnHering/i3
arch = i686
arch = x86_64
license = BSD
- makedepends = automake
makedepends = git
+ makedepends = bison
+ makedepends = flex
makedepends = asciidoc
- makedepends = docbook-xsl
makedepends = xmlto
- makedepends = perl
- makedepends = pkgconfig
+ makedepends = meson
depends = xcb-util-keysyms
depends = xcb-util-wm
depends = libev
@@ -23,12 +22,9 @@ pkgbase = i3-gaps-rounded-git
depends = xcb-util-cursor
depends = xcb-util-xrm
depends = libxkbcommon-x11
- optdepends = rxvt-unicode: The terminal emulator used in the default config.
- optdepends = dmenu: As menu.
+ depends = pcre2
optdepends = i3lock: For locking your screen.
optdepends = i3status: To display system information with a bar.
- optdepends = perl-json-xs: For i3-save-tree
- optdepends = perl-anyevent-i3: For i3-save-tree
provides = i3-wm
conflicts = i3-wm
conflicts = i3bar
@@ -37,9 +33,7 @@ pkgbase = i3-gaps-rounded-git
conflicts = i3-gaps-git
conflicts = i3-gaps
options = docs
- options = !strip
- source = git://github.com/resloved/i3#branch=shape
+ source = i3-gaps-rounded::git+https://github.com/FinnHering/i3.git
sha1sums = SKIP
pkgname = i3-gaps-rounded-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f628c94f19c6..9501a041c1bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,26 @@
-# Maintainer: Rhys Perry <rhysperry111@gmail.com>
+# Maintainer: Finn Hering <finn@hering.sh>
# Based on i3-gaps-next-git PKGBUILD
pkgname=i3-gaps-rounded-git
-pkgver=4.16.1.r184.g00181678
-pkgrel=3
+pkgver=4.20.1.r82.gad7c74ac
+pkgrel=2
pkgdesc='A fork of i3wm tiling window manager with more features, including gaps and rounded corners'
arch=('i686' 'x86_64')
-url='https://github.com/resloved/i3'
+url='https://github.com/FinnHering/i3'
license=('BSD')
provides=('i3-wm')
conflicts=('i3-wm' 'i3bar' 'i3bar-git' 'i3-git' 'i3-gaps-git' 'i3-gaps')
depends=('xcb-util-keysyms' 'xcb-util-wm' 'libev' 'yajl'
'startup-notification' 'pango' 'perl' 'xcb-util-cursor' 'xcb-util-xrm'
- 'libxkbcommon-x11')
-makedepends=('automake' 'git' 'asciidoc' 'docbook-xsl' 'xmlto' 'perl' 'pkgconfig')
-optdepends=('rxvt-unicode: The terminal emulator used in the default config.'
- 'dmenu: As menu.'
- 'i3lock: For locking your screen.'
- 'i3status: To display system information with a bar.'
- 'perl-json-xs: For i3-save-tree'
- 'perl-anyevent-i3: For i3-save-tree')
-options=('docs' '!strip')
-source=('git://github.com/resloved/i3#branch=shape')
+ 'libxkbcommon-x11' 'pcre2')
+makedepends=('git' 'bison' 'flex' 'asciidoc' 'xmlto' 'meson')
+optdepends=('i3lock: For locking your screen.'
+ 'i3status: To display system information with a bar.')
+options=('docs')
+source=('i3-gaps-rounded::git+https://github.com/FinnHering/i3.git')
sha1sums=('SKIP')
-_gitname='i3'
+_gitname='i3-gaps-rounded'
pkgver() {
cd "$srcdir/$_gitname"
@@ -33,29 +29,18 @@ pkgver() {
build() {
cd "$_gitname"
-
- autoreconf --force --install
-
- rm -rf build/
- mkdir -p build && cd build/
-
- ../configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --disable-sanitizers
-
- # See https://lists.archlinux.org/pipermail/arch-dev-public/2013-April/024776.html
- make CPPFLAGS+=" -fcommon"
+ arch-meson \
+ -Ddocs=true \
+ -Dmans=true \
+ ../build
+ meson compile -C ../build
}
package() {
cd "$_gitname"
- cd build/
-
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" meson install -C ../build
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 LICENSE
- install -Dm644 ../LICENSE \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et: