summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Qin2015-07-15 15:41:45 +0800
committerJustin Qin2015-07-15 15:41:45 +0800
commitd5c08fcadc0a9c6019fb4392fc86c493e753f50c (patch)
tree9b101f169b3ce6afbead0d028561314b071ba9c2
downloadaur-d5c08fcadc0a9c6019fb4392fc86c493e753f50c.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c037cd0162f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = i3-get-window-criteria
+ pkgdesc = Get criteria for use with i3 config commands
+ pkgver = git
+ pkgrel = 1
+ url = https://gist.github.com/ApocalypseQin/565458820faae65bb0d6
+ arch = any
+ license = custom
+ depends = xorg-xwininfo
+ depends = xorg-xprop
+ source = i3-get-window-criteria::git+https://gist.github.com/565458820faae65bb0d6.git
+ md5sums = SKIP
+
+pkgname = i3-get-window-criteria
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a92676858f1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Apocalypse <justin.qin@outlook.com>
+
+pkgname=i3-get-window-criteria
+pkgver=git
+pkgrel=1
+pkgdesc="Get criteria for use with i3 config commands"
+arch=('any')
+url="https://gist.github.com/ApocalypseQin/565458820faae65bb0d6"
+license=('custom')
+depends=('xorg-xwininfo' 'xorg-xprop')
+
+source=("${pkgname}::git+https://gist.github.com/565458820faae65bb0d6.git")
+
+md5sums=(SKIP)
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 i3-get-window-criteria.sh "$pkgdir/usr/bin/$pkgname"
+}