summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIngo Bürk2020-11-15 22:00:05 +0100
committerIngo Bürk2020-11-15 22:00:05 +0100
commit031e50fa733b13f9c59b20d52f4dc7844979f131 (patch)
tree170175abed78643473cfeb2c9ad10061850d6448
parentb08613b31960e653ed2ebdc408ad347e660aaa91 (diff)
downloadaur-031e50fa733b13f9c59b20d52f4dc7844979f131.tar.gz
cleanup
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD49
2 files changed, 29 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 458b8d4a2158..62cb3464c194 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,40 +1,35 @@
pkgbase = i3-git
pkgdesc = An improved dynamic tiling window manager
- pkgver = 4.19.r3.ga9014987
+ pkgver = 4.19.r4.g4b1ea08e
pkgrel = 1
url = http://i3wm.org/
arch = i686
arch = x86_64
+ groups = i3
groups = i3-vcs
license = BSD
- makedepends = git
+ makedepends = bison
+ makedepends = flex
makedepends = asciidoc
- makedepends = docbook-xsl
makedepends = xmlto
- makedepends = perl
- makedepends = pkgconfig
makedepends = meson
- depends = xcb-util-cursor
depends = xcb-util-keysyms
depends = xcb-util-wm
- depends = xcb-util-xrm
depends = libev
depends = yajl
depends = startup-notification
depends = pango
+ depends = perl
+ depends = xcb-util-cursor
+ depends = xcb-util-xrm
depends = libxkbcommon-x11
- optdepends = dmenu: As menu.
optdepends = i3lock: For locking your screen.
optdepends = i3status: To display system information with a bar.
- optdepends = perl: i3-save-tree and i3-dmenu-desktop
- optdepends = perl-anyevent-i3: Features like saving the layout.
- optdepends = perl-json-xs: Features like saving the layout.
provides = i3-wm
conflicts = i3-wm
- conflicts = i3bar
- conflicts = i3bar-git
+ conflicts = i3-gaps
+ conflicts = i3-gaps-next-git
options = docs
- options = !strip
source = git://github.com/i3/i3#branch=next
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e37e0765e0a0..3a5d701a8873 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,54 +5,45 @@
# This PKGBUILD was prepared for pacman 4.1 by William. Thank you. :-)
pkgname=i3-git
-pkgver=4.19.r3.ga9014987
+pkgver=4.19.r4.g4b1ea08e
pkgrel=1
pkgdesc='An improved dynamic tiling window manager'
arch=('i686' 'x86_64')
url='http://i3wm.org/'
license=('BSD')
provides=('i3-wm')
-conflicts=('i3-wm' 'i3bar' 'i3bar-git')
-groups=('i3-vcs')
-depends=(xcb-util-cursor xcb-util-keysyms xcb-util-wm xcb-util-xrm libev yajl startup-notification
- pango libxkbcommon-x11)
-makedepends=(git asciidoc docbook-xsl xmlto perl pkgconfig meson)
-optdepends=('dmenu: As menu.'
- 'i3lock: For locking your screen.'
- 'i3status: To display system information with a bar.'
- 'perl: i3-save-tree and i3-dmenu-desktop'
- 'perl-anyevent-i3: Features like saving the layout.'
- 'perl-json-xs: Features like saving the layout.')
-options=('docs' '!strip')
+conflicts=('i3-wm' 'i3-gaps' 'i3-gaps-next-git')
+groups=('i3' 'i3-vcs')
+depends=('xcb-util-keysyms' 'xcb-util-wm' 'libev' 'yajl'
+ 'startup-notification' 'pango' 'perl' 'xcb-util-cursor' 'xcb-util-xrm'
+ 'libxkbcommon-x11')
+makedepends=('bison' 'flex' 'asciidoc' 'xmlto' 'meson')
+optdepends=('i3lock: For locking your screen.'
+ 'i3status: To display system information with a bar.')
+options=('docs')
source=('git://github.com/i3/i3#branch=next')
sha1sums=('SKIP')
-_gitname='i3'
-
pkgver() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/i3"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$_gitname"
-
- rm -rf build
- mkdir -p build && cd build
-
- arch-meson ..
- meson compile
+ cd "i3"
+ arch-meson \
+ -Ddocs=true \
+ -Dmans=true \
+ ../build
+ meson compile -C ../build
}
package() {
- cd "$_gitname"
- cd build/
-
- DESTDIR="$pkgdir/" meson install
+ cd "i3"
+ DESTDIR="${pkgdir}" meson install -C ../build
- install -Dm644 ../LICENSE \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 LICENSE
}
# vim:set ts=2 sw=2 et: