summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Erik Rediger2015-06-09 16:02:01 +0200
committerJan-Erik Rediger2015-06-09 16:02:30 +0200
commit0386622427ebbc940c858633f9cafa777b4326e1 (patch)
treee2e5555da20af5d82f4c14dd3ee2be11951e85ce
downloadaur-0386622427ebbc940c858633f9cafa777b4326e1.tar.gz
init
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD81
2 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c3be3c074c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = i3-git
+ pkgdesc = An improved dynamic tiling window manager
+ pkgver = 4.9.1.r24.g10a5872
+ pkgrel = 1
+ url = http://i3wm.org/
+ arch = i686
+ arch = x86_64
+ groups = i3-vcs
+ license = BSD
+ makedepends = git
+ makedepends = asciidoc
+ makedepends = docbook-xsl
+ makedepends = pkgconfig
+ depends = xcb-util-keysyms
+ depends = xcb-util-wm
+ depends = libev
+ depends = yajl
+ depends = startup-notification
+ depends = pango
+ depends = perl
+ depends = xcb-util-cursor-git
+ depends = libxkbcommon-x11
+ optdepends = rxvt-unicode: The terminal emulator used in the default config.
+ optdepends = dmenu: As menu.
+ optdepends = i3lock: For locking your screen.
+ optdepends = i3status: To display system information with a bar.
+ optdepends = perl-json-xs: For i3-save-tree
+ optdepends = perl-anyevent-i3: For i3-save-tree
+ provides = i3-wm
+ conflicts = i3-wm
+ conflicts = i3bar
+ conflicts = i3bar-git
+ options = docs
+ options = !strip
+ source = git://github.com/i3/i3#branch=next
+ sha1sums = SKIP
+
+pkgname = i3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d23399bbdb75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: Thorsten Toepper <atsutane at freethoughts dot de>
+# Contributor: Jan-Erik Rediger <badboy at archlinux dot us>
+# Contributor: William Giokas <1007380@gmail.com>
+
+# This PKGBUILD was prepared for pacman 4.1 by William. Thank you. :-)
+
+pkgname=i3-git
+pkgver=4.9.1.r24.g10a5872
+pkgrel=1
+pkgdesc='An improved dynamic tiling window manager'
+arch=('i686' 'x86_64')
+url='http://i3wm.org/'
+license=('BSD')
+provides=('i3-wm')
+conflicts=('i3-wm' 'i3bar' 'i3bar-git')
+groups=('i3-vcs')
+depends=('xcb-util-keysyms' 'xcb-util-wm' 'libev' 'yajl'
+ 'startup-notification' 'pango' 'perl' 'xcb-util-cursor-git'
+ 'libxkbcommon-x11')
+makedepends=('git' 'asciidoc' 'docbook-xsl' 'pkgconfig')
+optdepends=('rxvt-unicode: The terminal emulator used in the default config.'
+ 'dmenu: As menu.'
+ 'i3lock: For locking your screen.'
+ 'i3status: To display system information with a bar.'
+ 'perl-json-xs: For i3-save-tree'
+ 'perl-anyevent-i3: For i3-save-tree')
+options=('docs' '!strip')
+source=('git://github.com/i3/i3#branch=next')
+sha1sums=('SKIP')
+
+_gitname='i3'
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_gitname"
+ make
+ make -C man
+}
+
+package() {
+ cd "$_gitname"
+
+ make DESTDIR="$pkgdir/" install
+
+ install -Dm644 man/i3.1 \
+ ${pkgdir}/usr/share/man/man1/i3.1
+ install -Dm644 man/i3bar.1 \
+ ${pkgdir}/usr/share/man/man1/i3bar.1
+ install -Dm644 man/i3-config-wizard.1 \
+ ${pkgdir}/usr/share/man/man1/i3-config-wizard.1
+ install -Dm644 man/i3-input.1 \
+ ${pkgdir}/usr/share/man/man1/i3-input.1
+ install -Dm644 man/i3-msg.1 \
+ ${pkgdir}/usr/share/man/man1/i3-msg.1
+ install -Dm644 man/i3-migrate-config-to-v4.1 \
+ ${pkgdir}/usr/share/man/man1/i3-migrate-config-to-v4.1
+ install -Dm644 man/i3-nagbar.1 \
+ ${pkgdir}/usr/share/man/man1/i3-nagbar.1
+ install -Dm644 man/i3-dmenu-desktop.1 \
+ ${pkgdir}/usr/share/man/man1/i3-dmenu-desktop.1
+ install -Dm644 man/i3-dump-log.1 \
+ ${pkgdir}/usr/share/man/man1/i3-dump-log.1
+ install -Dm644 man/i3-sensible-editor.1 \
+ ${pkgdir}/usr/share/man/man1/i3-sensible-editor.1
+ install -Dm644 man/i3-sensible-pager.1 \
+ ${pkgdir}/usr/share/man/man1/i3-sensible-pager.1
+ install -Dm644 man/i3-sensible-terminal.1 \
+ ${pkgdir}/usr/share/man/man1/i3-sensible-terminal.1
+
+ install -Dm644 LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+
+ make clean
+}
+
+# vim:set ts=2 sw=2 et:
+