summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDustin Willis Webber2017-01-10 17:28:39 -0500
committerDustin Willis Webber2017-01-10 17:28:39 -0500
commit56227bcf1d313dc3661d83b23a80f9eb358cf894 (patch)
treee135041097cf34ecd03ce4c90e635c63d2c26f7e
downloadaur-56227bcf1d313dc3661d83b23a80f9eb358cf894.tar.gz
i3-gnome-git
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c55f87a41c9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = i3-gnome
+ pkgdesc = Starts i3 inside a gnome session.
+ pkgver = 5.1.r2.g55ea56b
+ pkgrel = 1
+ url = https://github.com/TheMarex/i3-gnome
+ arch = any
+ license = MIT
+ conflicts = i3-gnome
+ source = git+https://github.com/TheMarex/i3-gnome.git
+ md5sums = SKIP
+
+pkgname = i3-gnome-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90e2afe02176
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Dustin Willis Webber <dustin.webber@gmail.com>
+pkgname=i3-gnome-git
+pkgbase=i3-gnome
+pkgver=5.1.r2.g55ea56b
+pkgrel=1
+pkgdesc="Starts i3 inside a gnome session."
+arch=("any")
+url="https://github.com/TheMarex/i3-gnome"
+license=("MIT")
+groups=()
+depends=()
+makedepends=()
+optdepends=()
+provides=()
+conflicts=("i3-gnome")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(git+https://github.com/TheMarex/i3-gnome.git)
+noextract=()
+md5sums=("SKIP")
+
+pkgver() {
+ cd $pkgbase
+ git describe --tags --long|sed -r "s,^[^0-9],,;s,([0-9]*-g),r\1,;s,[-_],.,g"
+}
+
+build() {
+ cd "$pkgbase"
+
+ make
+}
+
+package() {
+ cd "$pkgbase"
+
+ make DESTDIR="$pkgdir/" install
+}