summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Selinger2015-07-27 10:17:51 +0200
committerDaniel Selinger2015-07-27 10:17:51 +0200
commiteab8a2b9938f4b6d9a15ce8c2504d3d16f30b160 (patch)
tree5cd5a8dec4afcf34acf33222019845f00bab1eeb
downloadaur-eab8a2b9938f4b6d9a15ce8c2504d3d16f30b160.tar.gz
Initial import
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD73
2 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41ad794ba454
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = i3-kde
+ pkgdesc = An improved dynamic tiling window manager (with KDE patches)
+ pkgver = 4.10.2
+ pkgrel = 1
+ url = http://i3wm.org/
+ arch = i686
+ arch = x86_64
+ groups = i3-vcs
+ license = BSD
+ makedepends = git
+ makedepends = asciidoc
+ makedepends = docbook-xsl
+ makedepends = pkgconfig
+ depends = xcb-util-keysyms
+ depends = xcb-util-wm
+ depends = libev
+ depends = yajl
+ depends = startup-notification
+ depends = pango
+ depends = perl
+ depends = xcb-util-cursor
+ depends = libxkbcommon-x11
+ optdepends = rxvt-unicode: The terminal emulator used in the default config.
+ optdepends = dmenu: As menu.
+ optdepends = i3lock: For locking your screen.
+ optdepends = i3status: To display system information with a bar.
+ optdepends = perl-json-xs: For i3-save-tree
+ optdepends = perl-anyevent-i3: For i3-save-tree
+ provides = i3-wm
+ conflicts = i3-wm
+ conflicts = i3bar
+ options = docs
+ options = !strip
+ source = git+https://github.com/sLite/i3.git#branch=all-master
+ sha1sums = SKIP
+
+pkgname = i3-kde
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..232def79305b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Upstream Maintainer: Thorsten Toepper <atsutane at freethoughts dot de>
+# Maintainer: Daniel Selinger <daniel@slite.org>
+
+pkgname=i3-kde
+pkgver=4.10.2
+pkgrel=1
+pkgdesc='An improved dynamic tiling window manager (with KDE patches)'
+arch=('i686' 'x86_64')
+url='http://i3wm.org/'
+license=('BSD')
+provides=('i3-wm')
+conflicts=('i3-wm' 'i3bar')
+groups=('i3-vcs')
+depends=('xcb-util-keysyms' 'xcb-util-wm' 'libev' 'yajl'
+ 'startup-notification' 'pango' 'perl' 'xcb-util-cursor'
+ 'libxkbcommon-x11')
+makedepends=('git' 'asciidoc' 'docbook-xsl' 'pkgconfig')
+optdepends=('rxvt-unicode: The terminal emulator used in the default config.'
+ 'dmenu: As menu.'
+ 'i3lock: For locking your screen.'
+ 'i3status: To display system information with a bar.'
+ 'perl-json-xs: For i3-save-tree'
+ 'perl-anyevent-i3: For i3-save-tree')
+options=('docs' '!strip')
+source=('git+https://github.com/sLite/i3.git#branch=all-master')
+sha1sums=('SKIP')
+
+_gitname='i3'
+
+build() {
+ cd "$_gitname"
+ make
+ make -C man
+}
+
+package() {
+ cd "$_gitname"
+
+ make DESTDIR="$pkgdir/" install
+
+ install -Dm644 man/i3.1 \
+ ${pkgdir}/usr/share/man/man1/i3.1
+ install -Dm644 man/i3bar.1 \
+ ${pkgdir}/usr/share/man/man1/i3bar.1
+ install -Dm644 man/i3-config-wizard.1 \
+ ${pkgdir}/usr/share/man/man1/i3-config-wizard.1
+ install -Dm644 man/i3-input.1 \
+ ${pkgdir}/usr/share/man/man1/i3-input.1
+ install -Dm644 man/i3-msg.1 \
+ ${pkgdir}/usr/share/man/man1/i3-msg.1
+ install -Dm644 man/i3-migrate-config-to-v4.1 \
+ ${pkgdir}/usr/share/man/man1/i3-migrate-config-to-v4.1
+ install -Dm644 man/i3-nagbar.1 \
+ ${pkgdir}/usr/share/man/man1/i3-nagbar.1
+ install -Dm644 man/i3-dmenu-desktop.1 \
+ ${pkgdir}/usr/share/man/man1/i3-dmenu-desktop.1
+ install -Dm644 man/i3-dump-log.1 \
+ ${pkgdir}/usr/share/man/man1/i3-dump-log.1
+ install -Dm644 man/i3-sensible-editor.1 \
+ ${pkgdir}/usr/share/man/man1/i3-sensible-editor.1
+ install -Dm644 man/i3-sensible-pager.1 \
+ ${pkgdir}/usr/share/man/man1/i3-sensible-pager.1
+ install -Dm644 man/i3-sensible-terminal.1 \
+ ${pkgdir}/usr/share/man/man1/i3-sensible-terminal.1
+
+ install -Dm644 LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+
+ make clean
+}
+
+# vim:set ts=2 sw=2 et:
+