summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Avrett2018-08-30 12:48:44 -0600
committerKyle Avrett2018-08-30 12:48:44 -0600
commit1565f03f76d48c884f0b1af8459210783fdf8991 (patch)
tree02dd17b06a6d24b526c467e991d7080210f1bf34
downloadaur-1565f03f76d48c884f0b1af8459210783fdf8991.tar.gz
.gitignore PKGBUILD .SRCINFO
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore0
-rw-r--r--PKGBUILD19
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ab7dea2c9f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = i3-projects
+ pkgdesc = Project creation and management for i3-wm
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/zzelman/i3-projects
+ arch = any
+ license = GPL3
+ depends = i3-wm
+ depends = python3
+ depends = zenity
+ source = git+https://github.com/zzelman/i3-projects.git#tag=release/1.0.0
+ md5sums = SKIP
+
+pkgname = i3-projects
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0aaaae4cae2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Kyle Avrett <kyle dot avrett at gmail dot com>
+pkgname=i3-projects
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Project creation and management for i3-wm"
+arch=("any")
+url="https://github.com/zzelman/i3-projects"
+license=('GPL3')
+depends=('i3-wm' 'python3' 'zenity')
+source=("git+https://github.com/zzelman/i3-projects.git#tag=release/1.0.0")
+md5sums=("SKIP")
+
+package() {
+ cd i3-projects
+
+ mkdir -p $pkgdir/usr/bin
+ cp i3-projects $pkgdir/usr/bin
+ chmod 755 $pkgdir/usr/bin/i3-projects
+}