summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Crisci2017-08-02 15:58:02 -0400
committerTony Crisci2017-08-02 15:58:02 -0400
commit7f26f7d817a9ea2e5e3d0075dcbc76264c563e4a (patch)
tree3756340a786a54bbab6596806c31baf3c8f2cb07
downloadaur-7f26f7d817a9ea2e5e3d0075dcbc76264c563e4a.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ff94b04e09c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = i3-style
+ pkgdesc = Add styles and colorschemes to i3wm
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = https://github.com/acrisci/i3-style
+ arch = any
+ license = custom:BSD 2-Clause
+ makedepends = npm coffee-script
+ depends = nodejs
+ options = !emptydirs
+ source = https://github.com/acrisci/i3-style/archive/v0.10.0.tar.gz
+ sha256sums = e052063abe7a07f24bdc93e3aa18ff93b81282093b4641cfb245ba3b74baddf3
+
+pkgname = i3-style
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4728fdbaf67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Tony Crisci <tony@dubstepdish.com>
+pkgname=i3-style
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="Add styles and colorschemes to i3wm"
+arch=('any')
+url="https://github.com/acrisci/i3-style"
+license=('custom:BSD 2-Clause')
+depends=('nodejs')
+makedepends=('npm coffee-script')
+options=(!emptydirs)
+source=("https://github.com/acrisci/i3-style/archive/v$pkgver.tar.gz")
+sha256sums=("e052063abe7a07f24bdc93e3aa18ff93b81282093b4641cfb245ba3b74baddf3")
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p $pkgdir/usr
+ cake build
+ npm install --user root -g --prefix="$pkgdir/usr"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ find "${pkgdir}" -name "package.json" -exec sed -e "s|${pkgdir}||" -i {} \;
+ find "${pkgdir}" -name "package.json" -exec sed -e "s|${srcdir}||" -i {} \;
+}
+
+# vim:set ts=2 sw=2 et:
+