summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Crisci2017-08-02 17:13:13 -0400
committerTony Crisci2017-08-02 17:13:13 -0400
commitc0ce898cf9e165994e9c704b7c748da47236bebd (patch)
treea4302d2f02661009d9b5eececf2fd1c3014efe8b
parent4e67fb31fed57aed34612b2d3f4f926f8f8fe0fb (diff)
downloadaur-c0ce898cf9e165994e9c704b7c748da47236bebd.tar.gz
fix pkgbuild
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8d1d46438af..ea5c63e78e32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,19 +8,15 @@ url="https://github.com/acrisci/i3-style"
license=('custom:BSD 2-Clause')
depends=('nodejs')
makedepends=('npm' 'coffee-script')
-options=(!emptydirs)
-source=("https://github.com/acrisci/i3-style/archive/v$pkgver.tar.gz")
-sha256sums=("e052063abe7a07f24bdc93e3aa18ff93b81282093b4641cfb245ba3b74baddf3")
+source=(https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
+sha256sums=("eec470851b87304f18465c859759d3767acd6c141736c49d2fd49c172b114519")
package() {
- cd "$srcdir/$pkgname-$pkgver"
- mkdir -p "$pkgdir/usr"
- cake build
- npm install --user root -g --prefix="$pkgdir/usr"
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- find "${pkgdir}" -name "package.json" -exec sed -e "s|${pkgdir}||" -i {} \;
- find "${pkgdir}" -name "package.json" -exec sed -e "s|${srcdir}||" -i {} \;
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
}
# vim:set ts=2 sw=2 et:
-