summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFenner Macrae2018-04-03 09:59:26 -0700
committerFenner Macrae2018-04-03 09:59:26 -0700
commitd67817060e4301dbeed004e1b735cc5dad95ce4a (patch)
tree5c854fab62395921d4044b65d4da6854cc438f51
downloadaur-d67817060e4301dbeed004e1b735cc5dad95ce4a.tar.gz
Initial commit to AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee881a261078
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = i3-swallow-git
+ pkgdesc = Swallow a terminal window after a blocking application is run in i3
+ pkgver = r10.09d16e7
+ pkgrel = 1
+ url = https://github.com/jamesofarrell/i3-swallow
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = i3-wm
+ depends = i3ipc-python-git
+ conflicts = i3-swallow
+ source = i3-swallow::git+https://github.com/jamesofarrell/i3-swallow.git
+ md5sums = SKIP
+
+pkgname = i3-swallow-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea7a1fbad2ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Fenner Macrae <fmacrae.dev at gmail dot com>
+
+_pkgname=i3-swallow
+pkgname=$_pkgname-git
+pkgver=r10.09d16e7
+pkgrel=1
+pkgdesc="Swallow a terminal window after a blocking application is run in i3"
+arch=('any')
+url="https://github.com/jamesofarrell/i3-swallow"
+license=('MIT')
+depends=('i3-wm' 'i3ipc-python-git')
+makedepends=('git')
+conflicts=('i3-swallow')
+changelog=
+source=("${_pkgname}::git+${url}.git")
+md5sums=('SKIP')
+
+pkgver()
+{
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ install -Dm 755 i3-swallow "$pkgdir/usr/bin/i3-swallow"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: