summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2021-09-23 22:28:55 +0300
committerYigit Sever2021-09-23 22:28:55 +0300
commitde9c57d77d1af87ef1920b2382fcc15b12f372f1 (patch)
tree47426359bea9c64cac878fa4fcc69b5559346efe
parentd67817060e4301dbeed004e1b735cc5dad95ce4a (diff)
downloadaur-de9c57d77d1af87ef1920b2382fcc15b12f372f1.tar.gz
Get upstream changes, move to community dependency
- i3ipc-python-git dependency from aur has been replaced by python-i3ipc from the Community repo - The name of the executable is changed to `swallow` (from i3-swallow) to keep up with the upstream - The executable is now installed under '/usr/bin/' per Arch package guidelines
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee881a261078..a6eef6ee0be8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = i3-swallow-git
pkgdesc = Swallow a terminal window after a blocking application is run in i3
- pkgver = r10.09d16e7
+ pkgver = r66.7a9faed
pkgrel = 1
url = https://github.com/jamesofarrell/i3-swallow
arch = any
license = MIT
makedepends = git
depends = i3-wm
- depends = i3ipc-python-git
+ depends = python-i3ipc
conflicts = i3-swallow
source = i3-swallow::git+https://github.com/jamesofarrell/i3-swallow.git
md5sums = SKIP
pkgname = i3-swallow-git
-
diff --git a/PKGBUILD b/PKGBUILD
index ea7a1fbad2ff..e855409c6ebd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: Fenner Macrae <fmacrae.dev at gmail dot com>
+# Maintainer: Yigit Sever <yigit at yigitsever dot com>
+# Contributor: Fenner Macrae <fmacrae.dev at gmail dot com>
_pkgname=i3-swallow
pkgname=$_pkgname-git
-pkgver=r10.09d16e7
+pkgver=r66.7a9faed
pkgrel=1
pkgdesc="Swallow a terminal window after a blocking application is run in i3"
arch=('any')
url="https://github.com/jamesofarrell/i3-swallow"
license=('MIT')
-depends=('i3-wm' 'i3ipc-python-git')
+depends=('i3-wm' 'python-i3ipc')
makedepends=('git')
conflicts=('i3-swallow')
-changelog=
source=("${_pkgname}::git+${url}.git")
md5sums=('SKIP')
@@ -23,7 +23,7 @@ pkgver()
package() {
cd "$srcdir/${_pkgname}"
- install -Dm 755 i3-swallow "$pkgdir/usr/bin/i3-swallow"
+ install -Dm 755 swallow.py "${pkgdir}"/usr/bin/swallow
install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}