summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2019-05-02 10:34:14 +0200
committerJose Riha2019-05-02 10:34:14 +0200
commit333d94c52847b17b7e8ff803827cb3abd2a741a1 (patch)
tree6ee5d5b6947ab57330472fbb2d0bd8eb176188a4
downloadaur-333d94c52847b17b7e8ff803827cb3abd2a741a1.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
-rw-r--r--i3-volume.install9
-rw-r--r--i3volume-alsa.conf32
-rw-r--r--i3volume-pulseaudio.conf30
5 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed4f80f4d546
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu May 2 08:33:59 UTC 2019
+pkgbase = i3-volume
+ pkgdesc = Volume control and volume notifications for i3wm
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://github.com/hastinbe/i3-volume
+ install = i3-volume.install
+ arch = any
+ license = GPL
+ depends = notification-daemon
+ optdepends = alsa-utils: Support for ALSA
+ optdepends = pulseaudio: Support for Pulseaudio
+ source = https://github.com/hastinbe/i3-volume/archive/v1.6.1.tar.gz
+ source = i3volume-alsa.conf
+ source = i3volume-pulseaudio.conf
+ md5sums = 0d7ae084ebeed1f018b65418a6348e96
+ md5sums = ebb255f91630209a64491bb0fed9bc08
+ md5sums = c36135349c39cdd70d20242a673d0b21
+
+pkgname = i3-volume
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2f7d1ad95d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=i3-volume
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="Volume control and volume notifications for i3wm"
+arch=(any)
+url="https://github.com/hastinbe/i3-volume"
+license=('GPL')
+depends=('notification-daemon')
+optdepends=('alsa-utils: Support for ALSA' 'pulseaudio: Support for Pulseaudio')
+install=${pkgname}.install
+source=("https://github.com/hastinbe/${pkgname}/archive/v${pkgver}.tar.gz"
+ "i3volume-alsa.conf"
+ "i3volume-pulseaudio.conf")
+md5sums=('0d7ae084ebeed1f018b65418a6348e96'
+ 'ebb255f91630209a64491bb0fed9bc08'
+ 'c36135349c39cdd70d20242a673d0b21')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 volume "${pkgdir}/usr/bin/i3-volume"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/i3-volume/README.md"
+ install -Dm644 "${srcdir}/i3volume-alsa.conf" "${pkgdir}/usr/share/doc/i3-volume/i3volume-alsa.conf"
+ install -Dm644 "${srcdir}/i3volume-pulseaudio.conf" "${pkgdir}/usr/share/doc/i3-volume/i3volume-pulseaudio.conf"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/i3-volume.install b/i3-volume.install
new file mode 100644
index 000000000000..da976b8876a1
--- /dev/null
+++ b/i3-volume.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "Refer to i3volume-alsa.conf and i3volume-pulseaudio.conf in /usr/share/doc/i3-volume for initial configuration"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/i3volume-alsa.conf b/i3volume-alsa.conf
new file mode 100644
index 000000000000..2446f7747180
--- /dev/null
+++ b/i3volume-alsa.conf
@@ -0,0 +1,32 @@
+# Review the lines below and append to ~/.config/.i3/config
+
+## Volume control
+
+# Path to volume control, without trailing slash
+set $volumepath /usr/bin/i3-volume
+
+# Command for the status line (used with -t, requires -u)
+# ie: i3blocks, i3status
+set $statuscmd i3status
+
+# Signal used to update the status line (used with -u, requires -t)
+# i3blocks uses SIGRTMIN+10 by default
+# i3status uses SIGUSR1 by default
+set $statussig SIGUSR1
+
+# Amount to increase/decrease volume as a percentage (used with -i, -d)
+set $volumestep 5
+
+# alsa-utils settings
+#
+# To configure a default card, see https://www.alsa-project.org/main/index.php/Asoundrc
+#
+# Card number to control. (used with -a and -c)
+# If not specified, i3-volume will let `amixer` use a default.
+# List cards: aplay -l
+#set $alsacard 1
+
+# append "-c $alsacard" without quotes to override default card
+bindsym XF86AudioRaiseVolume exec $volumepath -anp -i $volumestep -t $statuscmd -u $statussig
+bindsym XF86AudioLowerVolume exec $volumepath -anp -d $volumestep -t $statuscmd -u $statussig
+bindsym XF86AudioMute exec $volumepath -amn -t $statuscmd -u $statussig
diff --git a/i3volume-pulseaudio.conf b/i3volume-pulseaudio.conf
new file mode 100644
index 000000000000..075333cd1234
--- /dev/null
+++ b/i3volume-pulseaudio.conf
@@ -0,0 +1,30 @@
+# Review the lines below and append to ~/.config/.i3/config
+
+## Volume control
+
+# Path to volume control, without trailing slash
+set $volumepath /usr/bin/i3-volume
+
+# Command for the status line (used with -t, requires -u)
+# ie: i3blocks, i3status
+set $statuscmd i3status
+
+# Signal used to update the status line (used with -u, requires -t)
+# i3blocks uses SIGRTMIN+10 by default
+# i3status uses SIGUSR1 by default
+set $statussig SIGUSR1
+
+# Amount to increase/decrease volume as a percentage (used with -i, -d)
+set $volumestep 5
+
+# pulseaudio-utils settings
+#
+# Symbolic name for sink (numeric index not supported) (used with -s $sinkname)
+# Recommended: comment out this setting and omit the -s option to use default sink
+# List sink names: pacmd list-sinks | awk -F "[<>]" '/^\s+name: <.*>/{print $2}'
+#set $sinkname alsa_output.pci-0000_00_1b.0.analog-stereo
+
+# Using pulseaudio-utils (append "-s $sinkname" without quotes to override default sink)
+bindsym XF86AudioRaiseVolume exec $volumepath -np -i $volumestep -t $statuscmd -u $statussig
+bindsym XF86AudioLowerVolume exec $volumepath -np -d $volumestep -t $statuscmd -u $statussig
+bindsym XF86AudioMute exec $volumepath -mn -t $statuscmd -u $statussig