summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormwellsa at gmail dot com2020-03-17 15:18:48 -0400
committermwellsa at gmail dot com2020-03-17 15:18:48 -0400
commit6e490e11de2d98924e2a13fa86847b244fee6b9c (patch)
treed2bd79c7f7b155ff41736de2cc3539ba3e665e86
downloadaur-6e490e11de2d98924e2a13fa86847b244fee6b9c.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3227cadd4b0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = i3-wk-switch-git
+ pkgdesc = Workspace switcher for i3 wm that emulates xmonad
+ pkgver = VERSION
+ pkgrel = 1
+ url = https://github.com/tmfink/i3-wk-switch
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = i3ipc-python-git
+ provides = i3-wk-switch
+ conflicts = i3-wk-switch
+ source = i3-wk-switch::git+https://github.com/tmfink/i3-wk-switch
+ md5sums = SKIP
+
+pkgname = i3-wk-switch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4dc7a23fa00d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mark Wells (halfhorn) com dot gmail at mwellsa
+pkgname="i3-wk-switch-git"
+pkgver=VERSION
+pkgrel=1
+pkgdesc="Workspace switcher for i3 wm that emulates xmonad"
+arch=('any')
+url="https://github.com/tmfink/i3-wk-switch"
+license=('MIT')
+groups=()
+depends=('i3ipc-python-git')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+${url}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ # Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p "$pkgdir/usr/bin"
+ mv "i3-wk-switch.py" "$pkgdir/usr/bin/i3-wk-switch"
+}