summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-08-12 01:15:37 +0300
committerorhun2020-08-12 01:15:37 +0300
commit9999dbeb61d1d2b7fbce6068e7604b6d7e799bb8 (patch)
tree4b70cb9912b414f8a34317333a5131bb6b71b0f3
downloadaur-9999dbeb61d1d2b7fbce6068e7604b6d7e799bb8.tar.gz
Release v1.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c42ec86d25d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = i3-workspace-brightness
+ pkgdesc = Utility to auto-adjust the brightness of i3wm workspaces
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/orhun/i3-workspace-brightness
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ source = i3-workspace-brightness-1.0.0.tar.gz::https://github.com/orhun/i3-workspace-brightness/archive/1.0.0.tar.gz
+ sha512sums = SKIP
+
+pkgname = i3-workspace-brightness
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6dbc7f49f6dc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/i3-workspace-brightness/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..295fc79afa6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+pkgname=i3-workspace-brightness
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Utility to auto-adjust the brightness of i3wm workspaces"
+arch=('x86_64')
+url="https://github.com/orhun/i3-workspace-brightness"
+license=('GPL3')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha512sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked --all-features
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+} \ No newline at end of file