summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuyLiner2023-02-27 19:04:41 -0500
committerGuyLiner2023-02-27 19:04:41 -0500
commit80aa96de9e755f1431d91f6967b5bd9f64229ccd (patch)
tree194ab8df739203496c3fa3ce6be16e4bbf30e4df
parent232fc3d6660a6d9c0a56440fec4f1712ee61f000 (diff)
downloadaur-80aa96de9e755f1431d91f6967b5bd9f64229ccd.tar.gz
Removed river as a dependency and added --locked to the cargo install command in the package() function
-rwxr-xr-xPKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e554b86e6ba8..3bc8a416c3c0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: GuyLiner <guyliner69@proton.me>
_pkgname='i3bar-river'
pkgname=${_pkgname}-git
-pkgver=r66.f54d43f
+pkgver=r67.9d3b703
pkgrel=1
pkgdesc="A port of i3bar for the river Wayland compositor"
url="https://github.com/MaxVerevkin/i3bar-river"
arch=('x86_64')
license=('GPL3')
-depends=(cairo pango river)
+depends=(cairo pango)
makedepends=(git cargo)
provides=("${pkgname}")
conflicts=("${pkgname}")
@@ -22,5 +22,5 @@ pkgver() {
package() {
cd "$srcdir/${_pkgname}"
export RUSTUP_TOOLCHAIN=stable
- cargo install --no-track --all-features --root "$pkgdir/usr/" --path .
+ cargo install --no-track --all-features --locked --root "$pkgdir/usr/" --path .
}