summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormatoro2019-09-09 08:28:22 -0400
committermatoro2019-09-09 08:28:22 -0400
commit636afa67b13c391eb00539e20a010e7d13527200 (patch)
tree0d76aa3bbe269ad8989688e370cbdd64dd2fc1fe
downloadaur-636afa67b13c391eb00539e20a010e7d13527200.tar.gz
i3blocks-contrib-git: initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb2487e62866
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = i3blocks-contrib-git
+ pkgdesc = Official repository of community contributed blocklets
+ pkgver = v1.4.0.r157.21708ed
+ pkgrel = 1
+ url = https://github.com/vivien/i3blocks
+ arch = x86_64
+ groups = i3
+ license = GPL3
+ makedepends = git
+ depends = glibc
+ backup = etc/i3blocks.conf
+ source = git+https://github.com/vivien/i3blocks-contrib
+ sha512sums = SKIP
+
+pkgname = i3blocks-contrib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a3644cea77d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: matoro <matoro@airmail.cc>
+# Contributor: Christian Rebischke <Chris.Rebischke@archlinux.org>
+# Contributor: Vlad M. <vlad@archlinux.net>
+# Contributor: Patrice Peterson <runiq at archlinux dot us>
+# Contributor: Vivien Didelot <vivien+aur@didelot.org>
+
+pkgname=i3blocks-contrib-git
+pkgver=v1.4.0.r157.21708ed
+pkgrel=1
+pkgdesc='Official repository of community contributed blocklets'
+arch=('x86_64')
+groups=('i3')
+url="https://github.com/vivien/i3blocks"
+license=('GPL3')
+makedepends=('git')
+depends=('glibc')
+source=("git+https://github.com/vivien/i3blocks-contrib")
+sha512sums=('SKIP')
+backup=('etc/i3blocks.conf')
+
+pkgver() {
+ cd "${srcdir}"/i3blocks-contrib
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package () {
+ cd "${srcdir}"/i3blocks-contrib
+ mkdir -p "${pkgdir}"/usr/lib/i3blocks
+ find . -mindepth 1 -maxdepth 1 -type d -not -path '*/\.*' -exec cp -r {} "${pkgdir}"/usr/lib/i3blocks/ \;
+}