summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Lublin2019-02-06 10:31:13 +0100
committerDaniel Lublin2019-02-06 10:31:13 +0100
commitc87a3951055d349ee246625c0894dab83d931004 (patch)
tree5cc56cbcf2ad223ea87ccd806621f329922d97d7
downloadaur-c87a3951055d349ee246625c0894dab83d931004.tar.gz
Init package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6cbddc126cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = i3gopher
+ pkgdesc = i3 wm helper rodent - focus last focused window per workspace
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/quite/i3gopher
+ arch = x86_64
+ license = BSD
+ makedepends = go-pie
+ source = https://github.com/quite/i3gopher/archive/v0.1.0.tar.gz
+ sha256sums = 4fc8c173c7ad63cb20d036403e275682daebd5553b33b9c5f7bc58363da6125f
+
+pkgname = i3gopher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36b9698a5627
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Daniel Lublin <daniel@lublin.se>
+
+pkgname=i3gopher
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='i3 wm helper rodent - focus last focused window per workspace'
+arch=('x86_64')
+url="https://github.com/quite/i3gopher"
+license=('BSD')
+makedepends=('go-pie')
+source=("$url/archive/v0.1.0.tar.gz")
+sha256sums=('4fc8c173c7ad63cb20d036403e275682daebd5553b33b9c5f7bc58363da6125f')
+
+build() {
+ cd $pkgname-$pkgver
+ go build \
+ -gcflags "all=-trimpath=$PWD" \
+ -asmflags "all=-trimpath=$PWD" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname .
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}