summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrandon Clifford2017-12-07 17:39:16 -0700
committerBrandon Clifford2017-12-07 17:39:16 -0700
commit621143df1bdf09a732e0888ee84b1eb4d1b14455 (patch)
tree191f59d5ca445f491665f9e07ba3baff120e426f
parent19f80bfa036ba8fe3ec286c6cb53e7bbf0308ef7 (diff)
downloadaur-621143df1bdf09a732e0888ee84b1eb4d1b14455.tar.gz
Update to support upstream autoconf builds and pull in latest features
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c062683f1ce8..2e0f7e2446d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
# Generated by mksrcinfo v8
-# Sun Oct 1 23:47:48 UTC 2017
+# Fri Dec 8 00:39:02 UTC 2017
pkgbase = i3lock-color-git
pkgdesc = An improved screenlocker based upon XCB and PAM with color configuration support
- pkgver = r365.baedc43
+ pkgver = r421.4318dbe
pkgrel = 1
- url = https://github.com/chrjguill/i3lock-color
+ url = https://github.com/PandorasFox/i3lock-color
arch = i686
arch = x86_64
license = MIT
makedepends = git
- makedepends = libxkbcommon-x11
depends = xcb-util-image
- depends = xcb-util-keysyms
depends = pam
depends = libev
- depends = libx11
depends = cairo
+ depends = libxkbcommon-x11
provides = i3lock
provides = i3lock-color
conflicts = i3lock
- source = git+https://github.com/chrjguill/i3lock-color.git
+ source = git+https://github.com/PandorasFox/i3lock-color.git
md5sums = SKIP
pkgname = i3lock-color-git
diff --git a/PKGBUILD b/PKGBUILD
index 1ff8e9fc2c95..098f515a0210 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
_gitname=i3lock-color
pkgname="$_gitname-git"
-pkgver=r365.baedc43
+pkgver=r421.4318dbe
pkgrel=1
pkgdesc="An improved screenlocker based upon XCB and PAM with color configuration support"
arch=('i686' 'x86_64')
-url="https://github.com/chrjguill/i3lock-color"
+url="https://github.com/PandorasFox/i3lock-color"
license=('MIT')
-depends=('xcb-util-image' 'xcb-util-keysyms' 'pam' 'libev' 'libx11' 'cairo')
+depends=('xcb-util-image' 'pam' 'libev' 'cairo' 'libxkbcommon-x11')
provides=('i3lock' 'i3lock-color')
conflicts=('i3lock')
-makedepends=('git' 'libxkbcommon-x11')
-source=("git+https://github.com/chrjguill/$_gitname.git")
+makedepends=('git')
+source=("git+https://github.com/PandorasFox/$_gitname.git")
md5sums=('SKIP')
pkgver() {
@@ -22,18 +22,21 @@ pkgver() {
prepare() {
cd "${srcdir}/${_gitname}"
- sed -i 's| -m 644 i3lock.1.gz| -Dm 644 i3lock.1.gz|' Makefile
}
build() {
cd "${srcdir}/${_gitname}"
# https://bugs.archlinux.org/task/31544
- sed -i -e 's:login:system-auth:' i3lock.pam
- make
+ sed -i -e 's:login:system-auth:' pam/i3lock
+
+ git tag -f "aur-$(git rev-parse --short HEAD)"
+ autoreconf -fi
+ ./configure --prefix="/usr" --sysconfdir="/etc"
+ make -j8
}
package() {
cd "${srcdir}/${_gitname}"
make DESTDIR="$pkgdir" install
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}