summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormeskarune2016-03-27 11:02:46 -0400
committermeskarune2016-03-27 11:02:46 -0400
commitfc3d3eb666618757fde1be9dd79ca93c9bbeb560 (patch)
treec095f69f182d8e6e0128b8c2a5329e848bfd6d38
downloadaur-fc3d3eb666618757fde1be9dd79ca93c9bbeb560.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
-rw-r--r--package.patch14
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f039850c2eee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Mar 27 15:02:19 UTC 2016
+pkgbase = i3lock-fancy-git
+ pkgdesc = i3lock-color script: blurs background, adds lock icon and text, offers dark/light background detection.
+ pkgver = r46.c30b2a1
+ pkgrel = 1
+ url = https://github.com/meskarune/i3lock-fancy
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = imagemagick
+ depends = i3lock-color-git
+ depends = scrot
+ provides = i3lock-fancy
+ source = git+https://github.com/meskarune/i3lock-fancy.git
+ md5sums = SKIP
+
+pkgname = i3lock-fancy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..699fbe5d8560
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Dolores Portalatin <meskarune at gmail dot com>
+# Contributor: burntcookie90 <aur at vishnurajeevan dot com>
+_gitname=i3lock-fancy
+pkgname=i3lock-fancy-git
+pkgver=r46.c30b2a1
+pkgrel=1
+pkgdesc="i3lock-color script: blurs background, adds lock icon and text, offers dark/light background detection."
+arch=('i686' 'x86_64')
+url="https://github.com/meskarune/i3lock-fancy"
+license=('MIT')
+depends=('imagemagick' 'i3lock-color-git' 'scrot')
+makedepends=('git')
+provides=("i3lock-fancy")
+source=("git+https://github.com/meskarune/$_gitname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ patch -N ${srcdir}/${_gitname}/lock ../package.patch
+}
+package() {
+ cd "${srcdir}/$_gitname"
+ install -Dm755 lock ${pkgdir}/usr/bin/i3lock-fancy
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${_gitname}/LICENSE
+ install -Dm644 lock.png ${pkgdir}/usr/share/${_gitname}/lock.png
+ install -Dm644 lockdark.png ${pkgdir}/usr/share/${_gitname}/lockdark.png
+}
diff --git a/package.patch b/package.patch
new file mode 100644
index 000000000000..a80345e8074a
--- /dev/null
+++ b/package.patch
@@ -0,0 +1,14 @@
+--- lock 2016-03-25 16:26:26.083985910 -0400
++++ lock-new 2016-03-27 10:28:53.597662747 -0400
+@@ -8,10 +8,7 @@
+ # Set your own font. List with "convert list font" in a terminal
+ #FONT="Noto-Sans"
+
+-# get path where the script is located to find the lock icon
+-pushd $(dirname $0) > /dev/null
+-SCRIPTPATH=$(pwd)
+-popd > /dev/null
++SCRIPTPATH="/usr/share/i3lock-fancy"
+
+ # l10n support
+ TEXT="Type password to unlock"