summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Tobler2016-07-24 18:15:19 +0200
committerLukas Tobler2016-07-24 18:15:19 +0200
commit18b9f12ce657c9a9862c9957ce72e03f7c556b0e (patch)
treef4332435a06a194c00cebc020cd9356f6a90e339
parenta8eb1765ed9cd5e04676ea6187e4f4f2188f22d9 (diff)
downloadaur-18b9f12ce657c9a9862c9957ce72e03f7c556b0e.tar.gz
Update, remove 24hour patch
-rw-r--r--.SRCINFO6
-rw-r--r--24hour.patch13
-rw-r--r--PKGBUILD18
3 files changed, 7 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c80b13d3bf0..78f0ba7e0f73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = i3lock-lixxia-git
pkgdesc = An improved screenlocker based upon XCB and PAM (Lixxia fork)
- pkgver = ff1273
- pkgrel = 2
+ pkgver = 7b59bd
+ pkgrel = 3
url = https://github.com/Lixxia/i3lock
arch = i686
arch = x86_64
@@ -17,9 +17,7 @@ pkgbase = i3lock-lixxia-git
options = docs
backup = etc/pam.d/i3lock
source = git://github.com/Lixxia/i3lock.git
- source = 24hour.patch
md5sums = SKIP
- md5sums = 03a4b583be31541921d3392984c95cba
pkgname = i3lock-lixxia-git
diff --git a/24hour.patch b/24hour.patch
deleted file mode 100644
index 9b5e91a51548..000000000000
--- a/24hour.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Only in b: tags
-diff -ru a/unlock_indicator.c b/unlock_indicator.c
---- a/unlock_indicator.c 2015-05-22 11:00:01.849040047 +0200
-+++ b/unlock_indicator.c 2015-05-22 11:00:45.945473675 +0200
-@@ -25,7 +25,7 @@
- #define BUTTON_SPACE (BUTTON_RADIUS + 5)
- #define BUTTON_CENTER (BUTTON_RADIUS + 5)
- #define BUTTON_DIAMETER (2 * BUTTON_SPACE)
--#define TIME_FORMAT "%l:%M %p"
-+#define TIME_FORMAT "%H:%M"
-
- /*******************************************************************************
- * Variables defined in i3lock.c.
diff --git a/PKGBUILD b/PKGBUILD
index 4824ead5f174..1d2b784fb05f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Adrien Sohier <adrien.sohier@art-software.fr>
pkgname=i3lock-lixxia-git
-pkgver=ff1273
-pkgrel=2
+pkgver=7b59bd
+pkgrel=3
pkgdesc="An improved screenlocker based upon XCB and PAM (Lixxia fork)"
arch=('i686' 'x86_64')
url="https://github.com/Lixxia/i3lock"
@@ -14,24 +14,16 @@ replaces=('i3lock')
provides=('i3lock')
conflicts=('i3lock')
backup=("etc/pam.d/i3lock")
-source=("git://github.com/Lixxia/i3lock.git"
- "24hour.patch")
-md5sums=('SKIP'
- '03a4b583be31541921d3392984c95cba')
+source=("git://github.com/Lixxia/i3lock.git")
+md5sums=('SKIP')
pkgver() {
cd "${srcdir}/i3lock"
git describe --always | cut -c2- | tr "-" "."
}
-prepare() {
- cd "${srcdir}/i3lock"
- patch -Np1 -i "${srcdir}/24hour.patch"
-}
-
build() {
cd "${srcdir}/i3lock"
-
make
gzip i3lock.1
}
@@ -39,7 +31,7 @@ build() {
package() {
cd "${srcdir}/i3lock"
make DESTDIR="${pkgdir}" install
-
+
install -Dm644 i3lock.1.gz ${pkgdir}/usr/share/man/man1/i3lock.1.gz
install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
make clean