summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors3lph2019-03-02 20:51:15 +0100
committers3lph2019-03-02 20:51:15 +0100
commit3c5397c3811d87f1ba094f7c7a10888a8768ab41 (patch)
tree2540cf0c3cd6ebc68c8254375ca7db418ae4e0d1
parentc7b5aa16351939920234b5a2beded3142f48a46b (diff)
downloadaur-3c5397c3811d87f1ba094f7c7a10888a8768ab41.tar.gz
lixxia/i3lock switched to autoconf instead of plain Makefile. This new version of the package implements this change in the build process.
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD32
3 files changed, 31 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb81ac6bc886..46bb924ed484 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = i3lock-lixxia-git
pkgdesc = An improved screenlocker based upon XCB and PAM (Lixxia fork)
- pkgver = r255.d0ca5ad
- pkgrel = 4
+ pkgver = r297.a27257f
+ pkgrel = 1
url = https://github.com/Lixxia/i3lock
arch = i686
arch = x86_64
groups = i3
license = MIT
+ makedepends = autoconf
+ makedepends = git
+ makedepends = gzip
+ makedepends = make
depends = xcb-util-image
depends = libev
depends = cairo
depends = libxkbcommon-x11
+ depends = pam
provides = i3lock
conflicts = i3lock
- replaces = i3lock
- options = docs
backup = etc/pam.d/i3lock
source = git://github.com/Lixxia/i3lock.git
md5sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d9e4e7fd4f09
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.pkg.tar.xz
+i3lock/
+src/
+pkg/
+
+*~
+\#*\# \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index d49e8ca8281c..ba1ecb9801a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
-# Maintainer: Lukas Tobler <luk4s.tobler@gmail.com>
+# Maintainer: s3lph <account-arch-aur-gzxkqqna at kernelpanic dot lol>
+# Contributor: Lukas Tobler <luk4s.tobler@gmail.com>
pkgname=i3lock-lixxia-git
-pkgver=r255.d0ca5ad
-pkgrel=4
+pkgver=r297.a27257f
+pkgrel=1
pkgdesc="An improved screenlocker based upon XCB and PAM (Lixxia fork)"
arch=('i686' 'x86_64')
url="https://github.com/Lixxia/i3lock"
license=('MIT')
-groups=("i3")
-depends=('xcb-util-image' 'libev' 'cairo' 'libxkbcommon-x11')
-options=('docs')
-replaces=('i3lock')
+groups=('i3')
+depends=('xcb-util-image' 'libev' 'cairo' 'libxkbcommon-x11' 'pam')
+makedepends=('autoconf' 'git' 'gzip' 'make')
provides=('i3lock')
conflicts=('i3lock')
backup=("etc/pam.d/i3lock")
@@ -24,17 +24,19 @@ pkgver() {
build() {
cd "${srcdir}/i3lock"
+ autoreconf -fi
+ mkdir -p build
+ gzip -c i3lock.1 > build/i3lock.1.gz
+ cd "${srcdir}/i3lock/build"
+ ../configure \
+ --prefix=${pkgdir}/usr \
+ --sysconfdir=${pkgdir}/etc
make
- gzip i3lock.1
}
package() {
- cd "${srcdir}/i3lock"
- make DESTDIR="${pkgdir}" install
-
+ cd "${srcdir}/i3lock/build"
+ make install
install -Dm644 i3lock.1.gz ${pkgdir}/usr/share/man/man1/i3lock.1.gz
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- make clean
+ install -Dm644 ../LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
-
-# vim:set ts=2 sw=2 et: