summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEsclapion2016-03-29 17:18:31 +0200
committerEsclapion2016-03-29 17:18:31 +0200
commit6386ec0d5067a6ddb1d117352cf5cd6bf0057da1 (patch)
treedafd5a908ca605a2bed532ae50851fdada110fbf
downloadaur-6386ec0d5067a6ddb1d117352cf5cd6bf0057da1.tar.gz
First submission
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf4fd15ccf9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Tue Mar 29 15:17:36 UTC 2016
+pkgbase = i3lock-shiver
+ pkgdesc = A fork of i3lock which introduces a blur option that does not rely on OpenGL
+ pkgver = 2.5
+ pkgrel = 20140424
+ url = http://i3wm.org
+ arch = i686
+ arch = x86_64
+ groups = i3-vcs
+ license = MIT
+ makedepends = git
+ depends = xcb-util-image
+ depends = libev
+ depends = cairo
+ depends = libxkbcommon
+ depends = libxkbfile
+ provides = i3lock
+ conflicts = i3lock
+ source = git+https://github.com/shiver/i3lock.git
+ sha1sums = SKIP
+
+pkgname = i3lock-shiver
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff449fafafb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Robert Vally <robert@vally.co.nz>
+pkgname=i3lock-shiver
+pkgver=2.5
+pkgrel=20140424
+pkgdesc='A fork of i3lock which introduces a blur option that does not rely on OpenGL'
+arch=('i686' 'x86_64')
+url='http://i3wm.org'
+license=('MIT')
+groups=('i3-vcs')
+provides=('i3lock')
+conflicts=('i3lock')
+depends=('xcb-util-image' 'libev' 'cairo' 'libxkbcommon' 'libxkbfile')
+makedepends=('git')
+source=('git+https://github.com/shiver/i3lock.git')
+sha1sums=('SKIP')
+
+_gitname='i3lock'
+
+#pkgver() {
+# cd "$srcdir/$_gitname"
+# git describe --tags | sed 's/-/./g'
+#}
+
+build() {
+ cd "$_gitname"
+ make
+ gzip i3lock.1
+}
+
+
+package() {
+ cd "$_gitname"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 i3lock.1.gz ${pkgdir}/usr/share/man/man1/i3lock.1.gz
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ make clean
+}
+
+# vim:set ts=2 sw=2 et: