summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiago Perrotta2015-06-14 02:31:21 -0300
committerThiago Perrotta2015-06-14 02:31:21 -0300
commit5e886144fb9f41af807e6a565a6c49876d24815a (patch)
tree1602cb2e6d428b909e5f17b477d17fe3b42b2718
downloadaur-5e886144fb9f41af807e6a565a6c49876d24815a.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c22bb304ddd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = i3lock-wrapper
+ pkgdesc = A simple wrapper around i3lock which blurs the current desktop
+ pkgver = 2015.04.28.g93a888c
+ pkgrel = 2
+ url = https://github.com/ashinkarov/i3-extras/
+ arch = any
+ groups = i3
+ license = ISC
+ makedepends = git
+ depends = i3lock
+ depends = scrot
+ depends = imagemagick
+ optdepends = bc: for using the -l option
+ optdepends = ghostscript: for using the -l option
+ source = git+https://github.com/ashinkarov/i3-extras
+ md5sums = SKIP
+
+pkgname = i3lock-wrapper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..456565f14503
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Thiago Perrotta <echo dGhpYWdvcGVycm90dGE5NUBnbWFpbC5jb20K | base64 -d >
+
+pkgname=i3lock-wrapper
+_gitname=i3-extras
+pkgver=2015.04.28.g93a888c
+pkgrel=2
+pkgdesc='A simple wrapper around i3lock which blurs the current desktop'
+arch=('any')
+url='https://github.com/ashinkarov/i3-extras/'
+license=('ISC')
+groups=('i3')
+depends=('i3lock' 'scrot' 'imagemagick')
+makedepends=('git')
+optdepends=('bc: for using the -l option'
+ 'ghostscript: for using the -l option')
+source=("git+https://github.com/ashinkarov/${_gitname}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git log -1 --format="%cd.g%h" --date=short | sed 's/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}