summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFuad Saud2021-01-08 19:30:29 -0300
committerFuad Saud2021-01-08 20:03:40 -0300
commitcc0161b81578dd822304324deb4a7291a65942ba (patch)
treea958381de10dac979cbe0bd4405c93811aba7680
downloadaur-i3lockr-bin.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--LICENSE-MIT.md26
-rw-r--r--PKGBUILD31
4 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebe801ed98c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = i3lockr-bin
+ pkgdesc = Distort a screenshot and run i3lock.
+ pkgver = 1.1.0_docfix
+ pkgrel = 1
+ url = https://github.com/owenthewizard/i3lockr
+ arch = x86_64
+ license = APACHE
+ license = MIT
+ depends = i3lock>=2.12
+ source = i3lockr-bin-1.1.0_docfix::https://github.com/owenthewizard/i3lockr/releases/download/v1.1.0-docfix/i3lockr
+ source = LICENSE-MIT.md
+ sha256sums = 086f33891af6268f1282ce6d41db2b910e3bc744b5c802033630306544b337dd
+ sha256sums = f69e4704af94bb7dc2462898e6484065d148d31a325f01e0da3652f7a501340e
+
+pkgname = i3lockr-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..77b0182fcc78
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.zip
+*.tar.gz
+*.xz
+*.zst
+pkg
+src
+i3lockr*
diff --git a/LICENSE-MIT.md b/LICENSE-MIT.md
new file mode 100644
index 000000000000..9394ef4d5db1
--- /dev/null
+++ b/LICENSE-MIT.md
@@ -0,0 +1,26 @@
+The MIT License (MIT)
+=====================
+
+Copyright © 2018 Owen Walpole
+
+Permission is hereby granted, free of charge, to any person
+obtaining a copy of this software and associated documentation
+files (the “Software”), to deal in the Software without
+restriction, including without limitation the rights to use,
+copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e86985cf9586
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Fuad Saud <fuadfsaud@gmail.com>
+pkgname=i3lockr-bin
+pkgver=1.1.0_docfix
+pkgrel=1
+epoch=
+pkgdesc='Distort a screenshot and run i3lock.'
+arch=('x86_64')
+url="https://github.com/owenthewizard/i3lockr"
+license=('APACHE' 'MIT')
+groups=()
+depends=('i3lock>=2.12')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}-${pkgver}::https://github.com/owenthewizard/i3lockr/releases/download/v${pkgver//_/-}/i3lockr"
+ "LICENSE-MIT.md")
+
+sha256sums=('086f33891af6268f1282ce6d41db2b910e3bc744b5c802033630306544b337dd'
+ 'f69e4704af94bb7dc2462898e6484065d148d31a325f01e0da3652f7a501340e')
+
+package() {
+ install -Dm755 "${pkgname}-${pkgver}" "${pkgdir}/usr/bin/i3lockr"
+ install -Dm644 LICENSE-MIT.md "${pkgdir}/usr/share/licenses/i3lockr-bin/LICENSE"
+}