summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2018-01-28 13:50:14 -0300
committerHugo Osvaldo Barrera2018-01-28 13:53:16 -0300
commitb75d47d13c4bffdb97a879608386b8137fb7e1ff (patch)
tree0f94e4cfe87e494ef7d6cd6efbe8a18456dc5ccf
parent30dda1e7e9063cb067fd0fb5303d674bb0110be3 (diff)
downloadaur-b75d47d13c4bffdb97a879608386b8137fb7e1ff.tar.gz
Package latest upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d53dc572aed4..1a1eb7801a08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Aug 31 17:03:02 UTC 2016
+# Sun Jan 28 16:53:09 UTC 2018
pkgbase = i3pystatus
pkgdesc = i3status replacement written in python for the i3 window manager
- pkgver = 3.35
+ pkgver = r1712.3eb12a3
pkgrel = 1
url = https://github.com/enkore/i3pystatus
arch = i686
@@ -20,8 +20,8 @@ pkgbase = i3pystatus
optdepends = python-pywapi: For the weather module.,
optdepends = python-basiciw: For the wireless module.
optdepends = python-colour: For the pulseaudio module.
- source = https://github.com/enkore/i3pystatus/archive/3.35.tar.gz
- md5sums = f3e70d903484469f77b3e8bf39466338
+ source = git+https://github.com/enkore/i3pystatus.git#commit=3eb12a361fef480426a5afb37ff772bbfd87d408
+ md5sums = SKIP
pkgname = i3pystatus
diff --git a/PKGBUILD b/PKGBUILD
index f5b18c8c254b..94c2df743da5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,16 @@
# Maintainer: Sebastien Bariteau <numkem@gmail.com>
+#
+# i3pystatus doesn't have releases; it's rolling release.
+# This package attempts to track recent stable versions, but is updated
+# manually so we can check that it buidls/runs.
+#
+# This'll be improved at some point to be an automated process.
+
+_pkgrev=3eb12a361fef480426a5afb37ff772bbfd87d408
pkgname=i3pystatus
pkgdesc="i3status replacement written in python for the i3 window manager"
-pkgver=3.35
+pkgver=r1712.3eb12a3
pkgrel=1
arch=('i686' 'x86_64')
license=('mit')
@@ -19,15 +27,20 @@ optdepends=('python-pyalsaaudio: For the alsa module.',
'python-basiciw: For the wireless module.'
'python-colour: For the pulseaudio module.')
url="https://github.com/enkore/i3pystatus"
-source=("https://github.com/enkore/i3pystatus/archive/$pkgver.tar.gz")
-md5sums=('f3e70d903484469f77b3e8bf39466338')
+source=("git+https://github.com/enkore/i3pystatus.git#commit=$_pkgrev")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "$srcdir/${pkgname}"
python setup.py build
}
package() {
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "$srcdir/${pkgname}"
python setup.py install --prefix=/usr --root="$pkgdir"
}