summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiancarlo Razzolini2024-05-13 12:05:27 -0300
committerGiancarlo Razzolini2024-05-13 12:05:27 -0300
commitadc6858eddd937d6b80f7705f4daa5cbeb1c9a2d (patch)
tree9833b29e9036b2cbaf14018b42560db227cac6cf
parent8736efe921edc3517d9025b4dfd7f398016c1696 (diff)
downloadaur-adc6858eddd937d6b80f7705f4daa5cbeb1c9a2d.tar.gz
Add the patch for python 3.12 to i3pystatus
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c90c4f7ddc97..c04f8401d92a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = i3pystatus-git
pkgdesc = i3status replacement written in python for the i3 window manager
- pkgver = 3.35.r370.gac71437
- pkgrel = 2
+ pkgver = 3.35.r403.g28ed5c1
+ pkgrel = 1
url = https://github.com/enkore/i3pystatus
arch = any
license = MIT
@@ -23,6 +23,8 @@ pkgbase = i3pystatus-git
provides = i3pystatus
conflicts = i3pystatus
source = i3pystatus-git::git+https://github.com/enkore/i3pystatus
+ source = python-3.12.patch::https://github.com/enkore/i3pystatus/pull/865.patch
md5sums = SKIP
+ md5sums = 7cb22a0fbdb4cc050d5ccc8d2e64541e
pkgname = i3pystatus-git
diff --git a/PKGBUILD b/PKGBUILD
index 4618b5556511..94dca6357029 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=i3pystatus-git
pkgdesc="i3status replacement written in python for the i3 window manager"
-pkgver=3.35.r370.gac71437
-pkgrel=2
+pkgver=3.35.r403.g28ed5c1
+pkgrel=1
arch=('any')
url="https://github.com/enkore/i3pystatus"
license=('MIT')
@@ -24,14 +24,21 @@ makedepends=('git' 'python-setuptools')
checkdepends=('python-pytest-runner' 'python-mock')
provides=('i3pystatus')
conflicts=('i3pystatus')
-source=("$pkgname::git+$url")
-md5sums=('SKIP')
+source=("$pkgname::git+$url"
+ "python-3.12.patch::https://github.com/enkore/i3pystatus/pull/865.patch")
+md5sums=('SKIP'
+ '7cb22a0fbdb4cc050d5ccc8d2e64541e')
pkgver() {
cd "$pkgname"
git describe --long --tags | sed 's/-/.r/;s/-/./'
}
+prepare () {
+ cd "$pkgname"
+ patch -Np1 -i ../python-3.12.patch
+}
+
build() {
cd "$pkgname"
python setup.py build