summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEliot Whalan2015-06-09 12:35:30 +1000
committerEliot Whalan2015-06-09 12:35:30 +1000
commit66ea0154df22d0761a8a3156cf58b01fb6b229bc (patch)
treef4c16348eb2ba8b55fe68f5308698f78148c54a6
downloadaur-66ea0154df22d0761a8a3156cf58b01fb6b229bc.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b32789088ded
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.1
+# Sat Apr 4 12:15:03 UTC 2015
+pkgbase = i3session-git
+ pkgdesc = Remembers what's running in your i3 workspaces by saving a session file
+ pkgver = 2013.10.07.g0189d6c
+ pkgrel = 1
+ url = https://github.com/joepestro/i3session
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2-xdg
+ depends = python2-i3-git
+ depends = i3-wm
+ depends = xorg-xprop
+ source = git://github.com/joepestro/i3session.git
+ md5sums = SKIP
+
+pkgname = i3session-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9f053235963
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: ewhal4 <ewhal4 at live dot com>
+# Contributor: Thiago Perrotta <echo dGhpYWdvcGVycm90dGE5NUBnbWFpbC5jb20K | base64 -d >
+_gitname=i3session
+pkgname=$_gitname-git
+pkgver=2013.10.07.g0189d6c
+pkgrel=1
+pkgdesc="Remembers what's running in your i3 workspaces by saving a session file"
+arch=('any')
+url="https://github.com/joepestro/$_gitname"
+license=('GPL')
+depends=(python2-xdg python2-i3-git i3-wm xorg-xprop)
+makedepends=('git')
+source=("git://github.com/joepestro/$_gitname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git log -1 --format="%cd.g%h" --date=short | sed 's/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ sed -i '1 s:/python:/env python2:' "$_gitname"
+ install -Dm755 $_gitname "$pkgdir/usr/bin/$_gitname"
+}