summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Erik Rediger2020-04-13 13:17:12 +0200
committerJan-Erik Rediger2020-04-13 13:17:12 +0200
commit04ae0a03e57e5a9ef3e5e739046f0186e827bf44 (patch)
tree0dd6e0162ce38222b2e51c3c592f40e2f551a2a2
parent199dc3e35262393aa470d09da4da096c2fbd5883 (diff)
downloadaur-04ae0a03e57e5a9ef3e5e739046f0186e827bf44.tar.gz
Version bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD22
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1b08597c6c9..e54e38da44ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = i3status-git
pkgdesc = Generates status bar to use with dzen2 or wmii
- pkgver = 2.13.r4.g54e798e
+ pkgver = 2.13.r69.gd088bae
pkgrel = 1
url = http://i3wm.org/i3status/
install = i3status.install
@@ -11,12 +11,12 @@ pkgbase = i3status-git
makedepends = git
makedepends = pkgconfig
makedepends = asciidoc
- makedepends = xmlto
depends = confuse
depends = alsa-lib
depends = yajl
depends = libpulse
depends = libnl
+ depends = xmlto
provides = i3status
conflicts = i3status
options = docs
diff --git a/PKGBUILD b/PKGBUILD
index 96403d88d2c9..082eaeb4f085 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
# Contributor: William Giokas <1007380@gmail.com>
pkgname=i3status-git
-pkgver=2.13.r4.g54e798e
+pkgver=2.13.r69.gd088bae
pkgrel=1
pkgdesc='Generates status bar to use with dzen2 or wmii'
arch=('i686' 'x86_64')
url='http://i3wm.org/i3status/'
license=('BSD')
groups=('i3-vcs')
-depends=('confuse' 'alsa-lib' 'yajl' 'libpulse' 'libnl')
-makedepends=('git' 'pkgconfig' 'asciidoc' 'xmlto')
+depends=('confuse' 'alsa-lib' 'yajl' 'libpulse' 'libnl' 'xmlto')
+makedepends=('git' 'pkgconfig' 'asciidoc')
options=('docs')
install=i3status.install
conflicts=('i3status')
@@ -27,27 +27,23 @@ pkgver() {
}
build() {
- cd "$_gitname"
-
+ cd "$srcdir/$_gitname"
autoreconf --force --install
- rm -rf build/
- mkdir -p build && cd build/
+ rm -rf build
+ mkdir build && cd build
../configure \
--prefix=/usr \
--sysconfdir=/etc \
--disable-sanitizers
- # See https://lists.archlinux.org/pipermail/arch-dev-public/2013-April/024776.html
- make CPPFLAGS+="-U_FORTIFY_SOURCE"
+ make
}
package() {
- cd "$_gitname"
- cd build/
-
- make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_gitname/build"
+ make DESTDIR="$pkgdir" install
install -Dm644 ../LICENSE \
${pkgdir}/usr/share/licenses/${pkgname}/LICENSE