summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Erik Rediger2015-06-09 16:15:31 +0200
committerJan-Erik Rediger2015-06-09 16:15:31 +0200
commit945c265153aad552761ca7b9ccc2aeef70a2d3b7 (patch)
tree8f3453c397e8f0eb6887c146baf7f2a977fa2e03
downloadaur-945c265153aad552761ca7b9ccc2aeef70a2d3b7.tar.gz
First commit in new AUR
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD43
-rw-r--r--i3status.install9
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c18c15168eff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = i3status-git
+ pkgdesc = Generates status bar to use with dzen2 or wmii
+ pkgver = 2.9.r20.g9abe0a9
+ pkgrel = 1
+ url = http://i3wm.org/i3status/
+ install = i3status.install
+ arch = i686
+ arch = x86_64
+ groups = i3-vcs
+ license = BSD
+ makedepends = git
+ makedepends = pkgconfig
+ makedepends = asciidoc
+ depends = wireless_tools
+ depends = confuse
+ depends = alsa-lib
+ depends = yajl
+ depends = libpulse
+ provides = i3status
+ conflicts = i3status
+ options = docs
+ source = git+https://github.com/i3/i3status
+ sha1sums = SKIP
+
+pkgname = i3status-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e0d0de7f4df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Thorsten Töpper <atsutane-aur@freethoughts.de>
+# Contributor: William Giokas <1007380@gmail.com>
+
+pkgname=i3status-git
+pkgver=2.9.r20.g9abe0a9
+pkgrel=1
+pkgdesc='Generates status bar to use with dzen2 or wmii'
+arch=('i686' 'x86_64')
+url='http://i3wm.org/i3status/'
+license=('BSD')
+groups=('i3-vcs')
+depends=('wireless_tools' 'confuse' 'alsa-lib' 'yajl' 'libpulse')
+makedepends=('git' 'pkgconfig' 'asciidoc')
+options=('docs')
+install=i3status.install
+conflicts=('i3status')
+provides=('i3status')
+source=(git+https://github.com/i3/i3status)
+sha1sums=('SKIP')
+
+_gitname='i3status'
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_gitname"
+ make
+}
+
+package() {
+ cd "$_gitname"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+
+ make clean
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/i3status.install b/i3status.install
new file mode 100644
index 000000000000..e86d21b80720
--- /dev/null
+++ b/i3status.install
@@ -0,0 +1,9 @@
+post_install() {
+ setcap 'CAP_NET_ADMIN=ep' /usr/bin/i3status
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: