summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2018-11-05 17:10:15 -0500
committerDaniel M. Capella2018-11-05 17:10:15 -0500
commit6e8340639d0299ac011dfc07f3f55d02ab3e94fa (patch)
tree1668a0caaf893585e36dbd922a2ca8dfbc07456d
parentfcc919ee461d10b0c837ebf5a6734c2ad63fb934 (diff)
downloadaur-6e8340639d0299ac011dfc07f3f55d02ab3e94fa.tar.gz
Require Cargo.lock is up to date
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29a8bc038255..817319ed73b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Jul 13 21:07:58 UTC 2018
+# Mon Nov 5 22:10:05 UTC 2018
pkgbase = i3status-rust
pkgdesc = Resourcefriendly and feature-rich replacement for i3status, written in pure Rust
pkgver = 0.9.0
@@ -9,7 +9,6 @@ pkgbase = i3status-rust
license = GPL3
makedepends = rust
depends = dbus
- depends = i3-wm
optdepends = alsa-utils: for the volume block
optdepends = lm_sensors: for the temperature block
optdepends = powerline-fonts: for all themes using the Powerline arrow char
diff --git a/PKGBUILD b/PKGBUILD
index 14405abbbbb0..2c263ccdca35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgdesc='Resourcefriendly and feature-rich replacement for i3status, written in
arch=('x86_64')
url=https://github.com/greshake/i3status-rust
license=('GPL3')
-depends=('dbus' 'i3-wm')
+depends=('dbus')
makedepends=('rust')
optdepends=('alsa-utils: for the volume block'
'lm_sensors: for the temperature block'
@@ -21,7 +21,7 @@ sha512sums=('0c5d62325d822b87d65e3b1b8c963f2ff0117b63c0bc2c0adc48575344bebbad2ce
build() {
cd $pkgname-$_commit
- cargo build --release
+ cargo build --release --locked
}
package() {