summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2017-08-06 08:25:10 -0400
committerDaniel M. Capella2017-08-06 08:58:53 -0400
commit84a04393c130c4d99e08b638ca0529252e3f3bcd (patch)
tree4deb1697fc9b54d77adf85e9ddd511ac4cbdb651
downloadaur-84a04393c130c4d99e08b638ca0529252e3f3bcd.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64cbf586cd72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Aug 6 12:57:53 UTC 2017
+pkgbase = i3status-rust
+ pkgdesc = Very resourcefriendly and feature-rich replacement for i3status, written in pure Rust
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/greshake/i3status-rust
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ depends = dbus
+ depends = i3-wm
+ optdepends = alsa-utils: for the volume block
+ optdepends = lm_sensors: for the temperature block
+ optdepends = powerline-fonts: for all themes using the powerline arrow char
+ optdepends = speedtest-cli: for the speedtest block
+ optdepends = ttf-font-awesome: for the Awesome icons
+ source = i3status-rust-0.9.0.tar.gz::https://github.com/greshake/i3status-rust/archive/b16a2c2b5b137f538f0992cd5553c83955257a3a.tar.gz
+ sha512sums = 0c5d62325d822b87d65e3b1b8c963f2ff0117b63c0bc2c0adc48575344bebbad2ce10b4d9ff308dcab263682123cfa29e6a22610cbd8b9842896bc4ea18a2f53
+
+pkgname = i3status-rust
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03282bbcb3b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Daniel M. Capella <polyzen@archlinux.info>
+
+_commit=b16a2c2b5b137f538f0992cd5553c83955257a3a
+pkgname=i3status-rust
+pkgver=0.9.0
+pkgrel=1
+pkgdesc='Very resourcefriendly and feature-rich replacement for i3status, written in pure Rust'
+arch=('i686' 'x86_64')
+url=https://github.com/greshake/i3status-rust
+license=('GPL3')
+depends=('dbus' 'i3-wm')
+makedepends=('cargo')
+optdepends=('alsa-utils: for the volume block'
+ 'lm_sensors: for the temperature block'
+ 'powerline-fonts: for all themes using the powerline arrow char'
+ 'speedtest-cli: for the speedtest block'
+ 'ttf-font-awesome: for the Awesome icons')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$_commit.tar.gz")
+sha512sums=('0c5d62325d822b87d65e3b1b8c963f2ff0117b63c0bc2c0adc48575344bebbad2ce10b4d9ff308dcab263682123cfa29e6a22610cbd8b9842896bc4ea18a2f53')
+
+build() {
+ cd $pkgname-$_commit
+ cargo build --release
+}
+
+package() {
+ cd $pkgname-$_commit
+ install -Dm755 target/release/i3status-rs "$pkgdir"/usr/bin/i3status-rs
+ install -Dm644 example_config.toml "$pkgdir"/usr/share/doc/$pkgname/examples/example_config.toml
+ install -Dm644 example_icon.toml "$pkgdir"/usr/share/doc/$pkgname/examples/example_icon.toml
+ install -Dm644 example_theme.toml "$pkgdir"/usr/share/doc/$pkgname/examples/example_theme.toml
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: