summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Sauter2023-03-16 21:50:06 +0100
committerMoritz Sauter2023-03-16 21:50:06 +0100
commit494725cb2d4744497357b9d0df168d61fabf6276 (patch)
tree5f809f1b8af85a33fd338eefc9936745573a6277
parent25d287f34dbb90e56269ff57211d833cf4b8dd15 (diff)
downloadaur-i3status-rust-full-git.tar.gz
chore: Update to new manpage building
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 234f2fa25f94..aac78fc71d3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = i3status-rust-full-git
license = GPL3
makedepends = git
makedepends = rust
+ makedepends = pandoc
depends = libpulse
depends = lm_sensors
depends = notmuch
diff --git a/PKGBUILD b/PKGBUILD
index 045ac334196d..24c23755632e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ arch=('x86_64')
url='https://github.com/greshake/i3status-rust'
license=('GPL3')
depends=('libpulse' 'lm_sensors' 'notmuch')
-makedepends=('git' 'rust')
+makedepends=('git' 'rust' 'pandoc')
optdepends=('alsa-utils: for the volume block'
'bluez: for the bluetooth block'
'fakeroot: for the pacman block to show pending updates'
@@ -33,6 +33,7 @@ pkgver() {
build() {
cd "${shortname}"
cargo build --release --features "pulseaudio maildir notmuch"
+ cargo xtask generate-manpage
}
package() {