diff options
author | Moritz Sauter | 2023-01-25 15:39:08 +0100 |
---|---|---|
committer | Moritz Sauter | 2023-01-25 15:39:08 +0100 |
commit | 4580ea94c22130d9a8de3b233f15caada521a0de (patch) | |
tree | feec0f6a6b1526502caa9e826c5657352204e786 | |
parent | 6edb16d6c811c17827d9860dfd96c64c4ebb01a3 (diff) | |
download | aur-4580ea94c22130d9a8de3b233f15caada521a0de.tar.gz |
Use clearer source name
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | .gitignore | 2 | ||||
-rw-r--r-- | PKGBUILD | 17 |
3 files changed, 12 insertions, 11 deletions
@@ -1,7 +1,7 @@ pkgbase = i3status-rust-full-git pkgdesc = Very resourcefriendly and feature-rich replacement for i3status to use with bar programs (like i3bar and swaybar), written in pure Rust pkgver = 0.30.0.r2998.g05b44ce1 - pkgrel = 1 + pkgrel = 2 url = https://github.com/greshake/i3status-rust install = i3status-rust.install arch = x86_64 @@ -22,7 +22,7 @@ pkgbase = i3status-rust-full-git optdepends = upower: for the battery block provides = i3status-rust conflicts = i3status-rust - source = i3status-rust-full::git+https://github.com/greshake/i3status-rust + source = i3status-rust::git+https://github.com/greshake/i3status-rust sha1sums = SKIP pkgname = i3status-rust-full-git diff --git a/.gitignore b/.gitignore index d64130fdd229..87b964f887f4 100644 --- a/.gitignore +++ b/.gitignore @@ -1,4 +1,4 @@ pkg src *zst -i3status-rust-full/ +i3status-rust/ @@ -1,8 +1,9 @@ # Maintainer: Moritz Sauter <moritz.sauter7+aur at gmail dot com> pkgname=i3status-rust-full-git +shortname="${pkgname%-full-*}" pkgver=0.30.0.r2998.g05b44ce1 -pkgrel=1 +pkgrel=2 pkgdesc='Very resourcefriendly and feature-rich replacement for i3status to use with bar programs (like i3bar and swaybar), written in pure Rust' arch=('x86_64') url='https://github.com/greshake/i3status-rust' @@ -18,24 +19,24 @@ optdepends=('alsa-utils: for the volume block' 'speedtest-cli: for the speedtest block' 'ttf-font-awesome: for the awesome icons' 'upower: for the battery block') -provides=("${pkgname%-full-*}") -conflicts=("${pkgname%-full-*}") -install="${pkgname%-full-*}.install" -source=("${pkgname%-*}::git+$url") +provides=("${shortname}") +conflicts=("${shortname}") +install="${shortname}.install" +source=("${shortname}::git+$url") sha1sums=('SKIP') pkgver() { - cd "${pkgname%-*}" + cd "${shortname}" echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).r$(git rev-list --count HEAD).g$(git describe --always) } build() { - cd "${pkgname%-*}" + cd "${shortname}" cargo build --release --all-features } package() { - cd "${pkgname%-*}" + cd "${shortname}" install -Dm755 target/release/i3status-rs "$pkgdir/usr/bin/i3status-rs" install -Dm644 man/i3status-rs.1 -t "$pkgdir/usr/share/man/man1" |