summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBryan Malyn2024-02-15 22:27:36 -0600
committerBryan Malyn2024-02-15 22:27:36 -0600
commit26da32f4ecc3aeb37207aa4d98bbd117c133dcf3 (patch)
treee3a1609a405c96d0fc14a4a0e1c41f9705da5f3e
parente8b46236bff0b44b22b52f1d416cd6612e478756 (diff)
downloadaur-26da32f4ecc3aeb37207aa4d98bbd117c133dcf3.tar.gz
Add libpipewire for privacy block
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4016ed2f212e..3f3e51e01715 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = i3status-rust-git
pkgdesc = Very resourcefriendly and feature-rich replacement for i3status to use with bar programs (like i3bar and swaybar), written in pure Rust
- pkgver = 0.32.3.r3432.g4a048bb1
- pkgrel = 3
+ pkgver = 0.32.3.r3445.g88cfdbe7
+ pkgrel = 1
url = https://github.com/greshake/i3status-rust
install = i3status-rust.install
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
makedepends = git
makedepends = rust
makedepends = pandoc
+ makedepends = clang
depends = libpulse
depends = lm_sensors
+ depends = libpipewire
optdepends = alsa-utils: for the volume block
optdepends = bluez: for the bluetooth block
optdepends = fakeroot: for the pacman block to show pending updates
optdepends = kdeconnect: for the kdeconnect block
+ optdepends = pipewire: for the privacy block
optdepends = powerline-fonts: for all themes using the powerline arrow char
optdepends = pulseaudio: for the volume block
optdepends = speedtest-cli: for the speedtest block
diff --git a/PKGBUILD b/PKGBUILD
index f12681506b15..76eea8ab653c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
# Contributor: Bryan Malyn <bim9262@gmail.com>
pkgname=i3status-rust-git
-pkgver=0.32.3.r3432.g4a048bb1
-pkgrel=3
+pkgver=0.32.3.r3445.g88cfdbe7
+pkgrel=1
pkgdesc='Very resourcefriendly and feature-rich replacement for i3status to use with bar programs (like i3bar and swaybar), written in pure Rust'
arch=('x86_64')
url='https://github.com/greshake/i3status-rust'
-license=('GPL3')
-depends=('libpulse' 'lm_sensors')
-makedepends=('git' 'rust' 'pandoc')
+license=('GPL-3.0-only')
+depends=('libpulse' 'lm_sensors' 'libpipewire')
+makedepends=('git' 'rust' 'pandoc' 'clang')
optdepends=('alsa-utils: for the volume block'
'bluez: for the bluetooth block'
'fakeroot: for the pacman block to show pending updates'
'kdeconnect: for the kdeconnect block'
+ 'pipewire: for the privacy block'
'powerline-fonts: for all themes using the powerline arrow char'
'pulseaudio: for the volume block'
'speedtest-cli: for the speedtest block'
@@ -39,7 +40,7 @@ build() {
cd "${pkgname%-*}"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
- cargo build --release --features 'pulseaudio maildir'
+ cargo build --release --features 'pulseaudio maildir pipewire'
cargo xtask generate-manpage
}