summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2017-07-13 20:06:36 +0200
committerJosip Ponjavic2017-07-13 20:06:36 +0200
commit7320b21a13caaee414febc2ac549d5750b04547b (patch)
tree0fc16fb3e39cbd035329a327448863bbfe62baaa
downloadaur-7320b21a13caaee414febc2ac549d5750b04547b.tar.gz
initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD36
-rw-r--r--i3status-rust.install9
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a334f87346b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = i3status-rust-git
+ pkgdesc = Very resourcefriendly and feature-rich replacement for i3status, written in pure Rust
+ pkgver = 0.1.0.r275.g6073151
+ pkgrel = 1
+ url = https://github.com/greshake/i3status-rust
+ install = i3status-rust.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ makedepends = git
+ depends = dbus
+ optdepends = alsa-utils: For volume block
+ optdepends = lm_sensors: For temperature block
+ provides = i3status-rust
+ conflicts = i3status-rust
+ source = git+https://github.com/greshake/i3status-rust
+ sha1sums = SKIP
+
+pkgname = i3status-rust-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a34f5efd6323
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+
+pkgname=i3status-rust-git
+pkgver=0.1.0.r275.g6073151
+pkgrel=1
+pkgdesc='Very resourcefriendly and feature-rich replacement for i3status, written in pure Rust'
+arch=('i686' 'x86_64')
+url='https://github.com/greshake/i3status-rust'
+license=('GPL3')
+depends=('dbus')
+makedepends=('cargo' 'git')
+optdepends=('alsa-utils: For volume block'
+ 'lm_sensors: For temperature block')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+install="${pkgname%-*}.install"
+source=("git+$url")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-*}"
+ echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).r$(git rev-list --count HEAD).g$(git describe --always)
+}
+
+build() {
+ cd "${pkgname%-*}"
+ cargo build --release
+}
+
+package() {
+ cd "${pkgname%-*}"
+ install -Dm755 target/release/i3status-rs "$pkgdir/usr/bin/i3status-rs"
+ install -Dm644 example_config.toml "$pkgdir/usr/share/doc/${pkgname%-*}/examples/example_config.toml"
+ install -Dm644 example_icon.toml "$pkgdir/usr/share/doc/${pkgname%-*}/examples/example_icon.toml"
+ install -Dm644 example_theme.toml "$pkgdir/usr/share/doc/${pkgname%-*}/examples/example_theme.toml"
+}
diff --git a/i3status-rust.install b/i3status-rust.install
new file mode 100644
index 000000000000..f747145f966a
--- /dev/null
+++ b/i3status-rust.install
@@ -0,0 +1,9 @@
+post_install() {
+echo ""
+echo "==> Copy example config file to .config dir:"
+echo "$ cp /usr/share/doc/i3status-rust/examples/example_config.toml ~/.config/i3/config.toml"
+echo ""
+echo "==> And edit bar section of the i3 config file."
+echo "status_command i3status-rs ~/.config/i3/config.toml"
+echo ""
+}