summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2018-10-03 13:58:31 +0200
committerJosip Ponjavic2018-10-03 13:58:31 +0200
commit892686f93bf7160034ddb88209362d30f6920df8 (patch)
treeea12a34e50117077c86bf5c79a4ed41f92784a61
parent48c661d9f4ddc66b3d4dfdccc08ab08d6a20114c (diff)
downloadaur-892686f93bf7160034ddb88209362d30f6920df8.tar.gz
add libpulse as depends and pulseaudio as optional
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e088522a9923..8c500506e639 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = i3status-rust-git
pkgdesc = Very resourcefriendly and feature-rich replacement for i3status to use with bar programs (like i3bar and swaybar), written in pure Rust
- pkgver = 0.9.0.r553.g4d2e595
+ pkgver = 0.9.0.r557.g07e5ffe
pkgrel = 1
url = https://github.com/greshake/i3status-rust
install = i3status-rust.install
@@ -8,18 +8,19 @@ pkgbase = i3status-rust-git
license = GPL3
makedepends = git
makedepends = rust
- depends = dbus
- optdepends = alsa-utils: For volume block
+ depends = libpulse
+ optdepends = alsa-utils: For the volume block
optdepends = curl: For the weather block
- optdepends = lm_sensors: For temperature block
- optdepends = networkmanager: For networkmanager block
+ optdepends = lm_sensors: For the temperature block
+ optdepends = networkmanager: For the networkmanager block
optdepends = powerline-fonts: For all themes using the powerline arrow char
+ optdepends = pulseaudio: For the volume block
optdepends = speedtest-cli: For the speedtest block
optdepends = ttf-font-awesome-4: For the awesome icons
optdepends = upower: For the battery block
provides = i3status-rust
conflicts = i3status-rust
- source = git+https://github.com/greshake/i3status-rust
+ source = i3status-rust::git+https://github.com/greshake/i3status-rust
sha1sums = SKIP
pkgname = i3status-rust-git
diff --git a/PKGBUILD b/PKGBUILD
index c2ee7adcff00..383fc1f34135 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=i3status-rust-git
-pkgver=0.9.0.r553.g4d2e595
+pkgver=0.9.0.r557.g07e5ffe
pkgrel=1
pkgdesc='Very resourcefriendly and feature-rich replacement for i3status to use with bar programs (like i3bar and swaybar), written in pure Rust'
arch=('x86_64')
url='https://github.com/greshake/i3status-rust'
license=('GPL3')
-depends=('dbus')
+depends=('libpulse')
makedepends=('git' 'rust')
-optdepends=('alsa-utils: For volume block'
+optdepends=('alsa-utils: For the volume block'
'curl: For the weather block'
- 'lm_sensors: For temperature block'
- 'networkmanager: For networkmanager block'
+ 'lm_sensors: For the temperature block'
+ 'networkmanager: For the networkmanager block'
'powerline-fonts: For all themes using the powerline arrow char'
+ 'pulseaudio: For the volume block'
'speedtest-cli: For the speedtest block'
'ttf-font-awesome-4: For the awesome icons'
'upower: For the battery block')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
install="${pkgname%-*}.install"
-source=("git+$url")
+source=("${pkgname%-*}::git+$url")
sha1sums=('SKIP')
pkgver() {
@@ -30,7 +31,7 @@ pkgver() {
build() {
cd "${pkgname%-*}"
- cargo build --release
+ cargo build --release --features "pulseaudio"
}
package() {