summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2020-04-25 14:45:39 +0200
committerJosip Ponjavic2020-04-25 14:45:39 +0200
commitde8f81a0d59769515c5c47100d29e1540666e31f (patch)
tree1c9770c0d2e91f04b2d4c7afa9cdee76e56d69db
parent09cb98d31731fa13c104f643342b6e8b724c8f67 (diff)
downloadaur-de8f81a0d59769515c5c47100d29e1540666e31f.tar.gz
upgpkg: 0.13.0.r940.ga42de8b-2 add fakeroot to optional depends
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD25
2 files changed, 26 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af9811a6f0a1..175b6d24ea65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = i3status-rust-git
pkgdesc = Very resourcefriendly and feature-rich replacement for i3status to use with bar programs (like i3bar and swaybar), written in pure Rust
- pkgver = 0.13.0.r860.ga866c59
+ pkgver = 0.13.0.r940.ga42de8b
pkgrel = 2
url = https://github.com/greshake/i3status-rust
install = i3status-rust.install
@@ -9,17 +9,18 @@ pkgbase = i3status-rust-git
makedepends = git
makedepends = rust
depends = libpulse
- optdepends = alsa-utils: For the volume block
- optdepends = bluez: For the bluetooth block
- optdepends = curl: For the weather block
- optdepends = ibus: For the ibus block
- optdepends = lm_sensors: For the temperature block
- optdepends = networkmanager: For the networkmanager block
- optdepends = powerline-fonts: For all themes using the powerline arrow char
- optdepends = pulseaudio: For the volume block
- optdepends = speedtest-cli: For the speedtest block
- optdepends = ttf-font-awesome-4: For the awesome icons
- optdepends = upower: For the battery block
+ optdepends = alsa-utils: for the volume block
+ optdepends = bluez: for the bluetooth block
+ optdepends = curl: for the weather block
+ optdepends = fakeroot: for the pacman block to show pending updates
+ optdepends = ibus: for the ibus block
+ optdepends = lm_sensors: for the temperature block
+ optdepends = networkmanager: for the networkmanager block
+ optdepends = powerline-fonts: for all themes using the powerline arrow char
+ optdepends = pulseaudio: for the volume block
+ optdepends = speedtest-cli: for the speedtest block
+ optdepends = ttf-font-awesome-4: for the awesome icons
+ optdepends = upower: for the battery block
provides = i3status-rust
conflicts = i3status-rust
source = i3status-rust::git+https://github.com/greshake/i3status-rust
diff --git a/PKGBUILD b/PKGBUILD
index 2cbf2b90f3b7..44328e9a3712 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=i3status-rust-git
-pkgver=0.13.0.r860.ga866c59
+pkgver=0.13.0.r940.ga42de8b
pkgrel=2
pkgdesc='Very resourcefriendly and feature-rich replacement for i3status to use with bar programs (like i3bar and swaybar), written in pure Rust'
arch=('x86_64')
@@ -9,17 +9,18 @@ url='https://github.com/greshake/i3status-rust'
license=('GPL3')
depends=('libpulse')
makedepends=('git' 'rust')
-optdepends=('alsa-utils: For the volume block'
- 'bluez: For the bluetooth block'
- 'curl: For the weather block'
- 'ibus: For the ibus block'
- 'lm_sensors: For the temperature block'
- 'networkmanager: For the networkmanager block'
- 'powerline-fonts: For all themes using the powerline arrow char'
- 'pulseaudio: For the volume block'
- 'speedtest-cli: For the speedtest block'
- 'ttf-font-awesome-4: For the awesome icons'
- 'upower: For the battery block')
+optdepends=('alsa-utils: for the volume block'
+ 'bluez: for the bluetooth block'
+ 'curl: for the weather block'
+ 'fakeroot: for the pacman block to show pending updates'
+ 'ibus: for the ibus block'
+ 'lm_sensors: for the temperature block'
+ 'networkmanager: for the networkmanager block'
+ 'powerline-fonts: for all themes using the powerline arrow char'
+ 'pulseaudio: for the volume block'
+ 'speedtest-cli: for the speedtest block'
+ 'ttf-font-awesome-4: for the awesome icons'
+ 'upower: for the battery block')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
install="${pkgname%-*}.install"