summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAline Abler2017-05-01 13:05:23 +0200
committerAline Abler2017-05-01 13:09:52 +0200
commitd3ab51a7d67c2c65dbca53361bafbe8c173eb874 (patch)
tree4d4930c555ab0a555c08900b1e286ee4e2a48a03
downloadaur-d3ab51a7d67c2c65dbca53361bafbe8c173eb874.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b43f245df0b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = i4oled
+ pkgdesc = Utility to set and render OLED icons on Wacom Intuos4 family tablets.
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://github.com/PrzemoF/i4oled
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = pango>=1.29.0
+ depends = cairo>=1.10.0
+ depends = libpng
+ source = https://github.com/PrzemoF/i4oled/archive/v1.3.tar.gz
+ md5sums = 3477a07133fe7d0f7b629b0b1a8d7cdc
+
+pkgname = i4oled
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17f6e80a98e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Aline Abler <alinea@riseup.net>
+# Contributor: Jason Gerecke <killertofu@gmail.com>
+
+
+pkgname=i4oled
+pkgver=1.3
+pkgrel=1
+pkgdesc="Utility to set and render OLED icons on Wacom Intuos4 family tablets."
+arch=('i686' 'x86_64')
+url="https://github.com/PrzemoF/i4oled"
+license=('GPL3')
+depends=('pango>=1.29.0' 'cairo>=1.10.0' 'libpng')
+source=("https://github.com/PrzemoF/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('3477a07133fe7d0f7b629b0b1a8d7cdc')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}