summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhoton892019-03-24 08:14:17 +0100
committerPhoton892019-03-24 08:14:17 +0100
commit2f48b1cda0389ad9000561b494181bb18c47b0fe (patch)
tree94795ad22e27445552662155f733b21720a43620
downloadaur-i4oled-gui.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cb16fe34041
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = i4oled-gui
+ pkgdesc = A graphical user interface for i4oled, a utility to set and render OLED icons on Wacom Intuos4 family tablets
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/PrzemoF/i4oled-gui
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = dconf
+ depends = gtk3
+ source = https://github.com/PrzemoF/i4oled-gui/archive/v1.2.tar.gz
+ md5sums = 7cd5c3e9beb89a0f053d8bb9ac13dbdf
+
+pkgname = i4oled-gui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e7742545b19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: PhotonX <photon89 [at] gmail.com>.
+
+pkgname=i4oled-gui
+pkgver=1.2
+pkgrel=1
+pkgdesc="A graphical user interface for i4oled, a utility to set and render OLED icons on Wacom Intuos4 family tablets"
+arch=('i686' 'x86_64')
+url="https://github.com/PrzemoF/i4oled-gui"
+license=('GPL2')
+depends=('dconf' 'gtk3')
+source=("https://github.com/PrzemoF/i4oled-gui/archive/v$pkgver.tar.gz")
+md5sums=('7cd5c3e9beb89a0f053d8bb9ac13dbdf')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./autogen.sh
+ ./configure
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="${pkgdir}" install
+} \ No newline at end of file