summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJannik Birk2017-09-20 20:29:52 +0200
committerJannik Birk2017-09-20 20:29:52 +0200
commit669f31f15e7a322423109ea88033587fe3264fb4 (patch)
treebdd8a32752cea8432554f5f2a318af732eacc357
parent961565b3271840816af4fb7e167851ea79cace3a (diff)
downloadaur-669f31f15e7a322423109ea88033587fe3264fb4.tar.gz
respect arch packaging standards
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31d268db7b36..ae45125580f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = i686-elf-binutils
pkgdesc = A set of programs to assemble and manipulate binary and object files for the i686-elf target
pkgver = 2.29
- pkgrel = 1
+ pkgrel = 2
url = http://www.gnu.org/software/binutils/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 33c5d27a797d..861cc8933f7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
_target=i686-elf
pkgname=$_target-binutils
pkgver=2.29
-pkgrel=1
+pkgrel=2
pkgdesc='A set of programs to assemble and manipulate binary and object files for the i686-elf target'
arch=(i686 x86_64)
url='http://www.gnu.org/software/binutils/'
license=(GPL)
depends=(zlib)
+options=(!emptydirs !docs)
source=("http://mirrors.kernel.org/gnu/binutils/binutils-$pkgver.tar.xz"
"libiberty-ignore-cflags.patch")
sha256sums=('0b871e271c4c620444f8264f72143b4d224aa305306d85dd77ab8dce785b1e85'
@@ -28,8 +29,9 @@ build() {
$srcdir/$_basedir/configure \
--target=$_target \
- --with-sysroot=/usr/$_target \
- --prefix=/usr \
+ --with-sysroot=${_target} \
+ --prefix=${_sysroot} \
+ --bindir=/usr/bin \
--disable-nls \
--disable-werror
@@ -48,9 +50,5 @@ package() {
make DESTDIR="$pkgdir" install
- # Remove file conflicting with host binutils and manpages for MS Windows tools
- rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,nlmconv,windres,windmc}*
-
- # Remove info documents that conflict with host version
- rm -rf "$pkgdir"/usr/share/info
+ rm -r ${pkgdir}/${_sysroot}/share/{info,man}
}