summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrandomnobody2022-08-26 01:15:39 +0000
committerrandomnobody2022-08-25 18:29:01 -0700
commitc6e2d11b9e95d2b701ed2ed2c47c89d3f31ee9ff (patch)
treef137e24f4ec66393e80ac4057ecc877b60a0dc75
parentfd2c76ff7288582d0cc9f11f76e15bea68d72da3 (diff)
downloadaur-c6e2d11b9e95d2b701ed2ed2c47c89d3f31ee9ff.tar.gz
adopted, updated to 2.39, removed libiberty patch (complain if issues)
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
-rw-r--r--libiberty-ignore-cflags.patch16
3 files changed, 15 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fd32b9479a1..d36320a737b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = i686-elf-binutils
pkgdesc = A set of programs to assemble and manipulate binary and object files for the i686-elf target
- pkgver = 2.36.1
- pkgrel = 2
+ pkgver = 2.39
+ pkgrel = 1
url = http://www.gnu.org/software/binutils/
arch = i686
arch = x86_64
@@ -10,12 +10,10 @@ pkgbase = i686-elf-binutils
depends = libelf
options = !emptydirs
options = !docs
- source = http://mirrors.kernel.org/gnu/binutils/binutils-2.36.1.tar.xz
- source = https://mirrors.kernel.org/gnu/binutils/binutils-2.36.1.tar.xz.sig
- source = libiberty-ignore-cflags.patch
+ source = https://mirrors.kernel.org/gnu/binutils/binutils-2.39.tar.xz
+ source = https://mirrors.kernel.org/gnu/binutils/binutils-2.39.tar.xz.sig
validpgpkeys = 3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F
- sha256sums = e81d9edf373f193af428a0f256674aea62a9d74dfe93f65192d4eae030b0f3b0
+ sha256sums = 645c25f563b8adc0a81dbd6a41cffbf4d37083a382e02d5d3df4f65c09516d00
sha256sums = SKIP
- sha256sums = 8b2aea00e98f7c311b1d0fb14e4b435a03c65fde32bc992c924edb6fa7b83c9c
pkgname = i686-elf-binutils
diff --git a/PKGBUILD b/PKGBUILD
index 77eb6a67b04a..12d0a2c1baff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,25 @@
-# Maintainer: Finlay Maroney <finman292004@protonmail.com>
+# Maintainer: randomnobody <nobody "at" 420blaze "dot" it>
+# Contributor: Finlay Maroney <finman292004@protonmail.com>
_target=i686-elf
pkgname=$_target-binutils
-pkgver=2.36.1
-pkgrel=2
+pkgver=2.39
+pkgrel=1
pkgdesc='A set of programs to assemble and manipulate binary and object files for the i686-elf target'
arch=(i686 x86_64)
url='http://www.gnu.org/software/binutils/'
license=(GPL)
depends=(zlib libelf)
options=(!emptydirs !docs)
-source=("http://mirrors.kernel.org/gnu/binutils/binutils-$pkgver.tar.xz"
- "https://mirrors.kernel.org/gnu/binutils/binutils-$pkgver.tar.xz.sig"
- "libiberty-ignore-cflags.patch")
+source=("https://mirrors.kernel.org/gnu/binutils/binutils-$pkgver.tar.xz"
+ "https://mirrors.kernel.org/gnu/binutils/binutils-$pkgver.tar.xz.sig")
_basedir=binutils-$pkgver
-sha256sums=('e81d9edf373f193af428a0f256674aea62a9d74dfe93f65192d4eae030b0f3b0'
- 'SKIP'
- '8b2aea00e98f7c311b1d0fb14e4b435a03c65fde32bc992c924edb6fa7b83c9c')
+sha256sums=('645c25f563b8adc0a81dbd6a41cffbf4d37083a382e02d5d3df4f65c09516d00'
+ 'SKIP')
validpgpkeys=("3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F")
prepare() {
cd $_basedir
- patch -p1 -i $srcdir/libiberty-ignore-cflags.patch
-
mkdir $srcdir/binutils-build
}
@@ -34,7 +31,7 @@ build() {
--with-sysroot \
--prefix=/usr \
--bindir=/usr/bin \
- --libdir=/usr/lib/i686-elf/ \
+ --libdir=/usr/lib/i686-elf/ \
--disable-nls \
--disable-werror
@@ -43,7 +40,7 @@ build() {
check() {
cd binutils-build
-
+
# do not abort on errors - manually check log files
make -k check
}
@@ -55,4 +52,3 @@ package() {
rm -r ${pkgdir}/usr/share/{info,man}
}
-
diff --git a/libiberty-ignore-cflags.patch b/libiberty-ignore-cflags.patch
deleted file mode 100644
index ddef5a472478..000000000000
--- a/libiberty-ignore-cflags.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -p1 -r a/libiberty/configure b/libiberty/configure
-*** a/libiberty/configure Tue Jul 4 20:43:21 2017
---- b/libiberty/configure Fri Aug 25 01:41:25 2017
-***************
-*** 10,11 ****
---- 10,19 ----
- # gives unlimited permission to copy, distribute and modify it.
-+
-+ ## ---------------------------------------------------------- ##
-+ ## PATCHED: Unset CFLAGS/CPPFLAGS so that libiberty compiles. ##
-+ ## ---------------------------------------------------------- ##
-+
-+ CFLAGS=
-+ CPPFLAGS=
-+
- ## -------------------- ##