summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Tremblay2017-03-14 10:19:58 -0400
committerGabriel Tremblay2017-03-14 10:19:58 -0400
commit03bba6020b688059f90d0443015480bda27f56c4 (patch)
tree907af6d0db10429a9866d1efa2b77a8e7bc7e6d2
parent8dd781c7571c68267f06e81ba4a6a9ec65beee9b (diff)
downloadaur-03bba6020b688059f90d0443015480bda27f56c4.tar.gz
Removed unused Makefile. Fixed service file
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--fix_Makefile.patch29
3 files changed, 6 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3955c4531edd..e34623c0ff9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = i8kutils-git
pkgdesc = Fan control for Dell laptops
- pkgver = 20170306.976c36a
- pkgrel = 1
+ pkgver = 20170307.83622d1
+ pkgrel = 3
url = https://github.com/vitorafsr/i8kutils
arch = i686
arch = x86_64
@@ -14,11 +14,9 @@ pkgbase = i8kutils-git
conflicts = i8kutils
backup = etc/i8kutils/i8kmon.conf
source = git+https://github.com/vitorafsr/i8kutils.git
- source = fix_Makefile.patch
source = i8kmon.service
sha1sums = SKIP
- sha1sums = fe5407464f59c023c5b52fdadd3275abdac720a4
- sha1sums = 5c20f5241de7e60b46117269f4e867b08734cdc8
+ sha1sums = 370d2675d98d7754a265f9b1578975693204f681
pkgname = i8kutils-git
diff --git a/PKGBUILD b/PKGBUILD
index 0a5ac87a2561..a65c897b6a51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Gabriel Tremblay gabriel@delvelabs.ca
pkgname=i8kutils-git
_pkgname=i8kutils
-pkgrel=2
-pkgver=20170306.976c36a
+pkgrel=3
+pkgver=20170307.83622d1
pkgdesc="Fan control for Dell laptops"
makedepends=("git")
conflicts=("$_pkgname")
@@ -13,12 +13,10 @@ depends=("bash")
optdepends=("tcl: for i8kmon daemon" "acpi: for i8kmon daemon" "tk: for i8kmon GUI mode")
backup=("etc/$_pkgname/i8kmon.conf")
source=("git+https://github.com/vitorafsr/$_pkgname.git"
- "fix_Makefile.patch"
"i8kmon.service")
sha1sums=("SKIP"
- "fe5407464f59c023c5b52fdadd3275abdac720a4"
- "5c20f5241de7e60b46117269f4e867b08734cdc8")
+ "370d2675d98d7754a265f9b1578975693204f681")
prepare() {
cd $srcdir
diff --git a/fix_Makefile.patch b/fix_Makefile.patch
deleted file mode 100644
index 38fc8d9e296f..000000000000
--- a/fix_Makefile.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -Naur i8kutils/Makefile i8kutils_new/Makefile
---- i8kutils/Makefile 2014-12-09 16:40:11.000000000 +0100
-+++ i8kutils_new/Makefile 2015-01-31 13:15:21.031912744 +0100
-@@ -14,16 +14,19 @@
- # General Public License for more details.
-
- ccflags-y = -Wall
-+CC = gcc
-
- all: i8kctl probe_i8k_calls_time
-
--i8kctl: i8kctl.c i8kctl.o
-- gcc -Wall i8kctl.c -o i8kctl
-+i8kctl: i8kctl.c
-+ $(CC) $(CFLAGS) $(LDFLAGS) -Wall i8kctl.c -o i8kctl
-
--probe_i8k_calls_time: probe_i8k_calls_time.c
-- gcc -Wall -c -g -DLIB i8kctl.c
-- gcc -Wall -c -g -DLIB probe_i8k_calls_time.c
-- gcc -o probe_i8k_calls_time i8kctl.o probe_i8k_calls_time.o
-+i8kctl_DLIB.o: i8kctl.c
-+ $(CC) $(CFLAGS) -Wall -c -g -DLIB i8kctl.c -o i8kctl_DLIB.o
-+
-+probe_i8k_calls_time: i8kctl_DLIB.o probe_i8k_calls_time.c
-+ $(CC) $(CFLAGS) -Wall -c -g -DLIB probe_i8k_calls_time.c
-+ $(CC) $(CFLAGS) $(LDFLAGS) -Wall -o probe_i8k_calls_time i8kctl_DLIB.o probe_i8k_calls_time.o
-
- i8k:
- make -C /lib/modules/$(shell uname -r)/build M=$(PWD) modules