summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebRmv2015-06-07 08:50:32 +0200
committerSebRmv2015-06-07 08:50:32 +0200
commita64c9eee51dd328dd5fa1a6a526110fdda3ff8b1 (patch)
treec3ceb91abb816a8701cd24c3190d05ed60074d48
downloadaur-a64c9eee51dd328dd5fa1a6a526110fdda3ff8b1.tar.gz
Initial import.
-rw-r--r--.SRCINFO19
-rw-r--r--Makefile9
-rw-r--r--PKGBUILD27
-rw-r--r--ia32_aout.install12
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ad482be3d4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ia32_aout
+ pkgdesc = ia32_aout kernel module, for running an a.out binary format
+ pkgver = 4.0
+ pkgrel = 1
+ url = https://www.kernel.org
+ install = ia32_aout.install
+ arch = x86_64
+ license = GPLv3
+ makedepends = linux-headers
+ makedepends = linux-api-headers
+ makedepends = gzip
+ options = !strip
+ source = https://raw.githubusercontent.com/torvalds/linux/v{4.0}/arch/x86/ia32/ia32_aout.c
+ source = Makefile
+ sha1sums = c635114660009c57014eb2a38e50e3abbb5f2e5f
+ sha1sums = 7afa0aad8856552718cc4c2b49625965537406a9
+
+pkgname = ia32_aout
+
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..0a0024d6394b
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,9 @@
+obj-m := ia32_aout.o
+KDIR := /lib/modules/$(shell uname -r)/build
+PWD := $(shell pwd)
+
+default:
+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
+
+install:
+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules_install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4edba056fd77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: SebRmv
+pkgname=ia32_aout
+pkgver=4.0
+pkgrel=1
+pkgdesc='ia32_aout kernel module, for running an a.out binary format'
+arch=('x86_64')
+makedepends=('linux-headers' 'linux-api-headers' 'gzip')
+url="https://www.kernel.org"
+license=("GPLv3")
+options=('!strip')
+source=("https://raw.githubusercontent.com/torvalds/linux/v{$pkgver}/arch/x86/ia32/ia32_aout.c"
+ "Makefile")
+sha1sums=('c635114660009c57014eb2a38e50e3abbb5f2e5f'
+ '7afa0aad8856552718cc4c2b49625965537406a9')
+install=ia32_aout.install
+
+build(){
+ cd "$srcdir"
+ make
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "${pkgdir}"/lib/modules
+ make install INSTALL_MOD_PATH="${pkgdir}"
+# gzip "${pkgdir}/lib/modules/`uname -r`/extra/ia32_aout.ko"
+}
diff --git a/ia32_aout.install b/ia32_aout.install
new file mode 100644
index 000000000000..95266cb60b62
--- /dev/null
+++ b/ia32_aout.install
@@ -0,0 +1,12 @@
+post_install() {
+ depmod -a
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+